Bug 1467837 - [Errno 2] No such file or directory: '/var/lib/rhsm/cache/rhsm_icon.json
[Errno 2] No such file or directory: '/var/lib/rhsm/cache/rhsm_icon.json
Status: CLOSED DUPLICATE of bug 1448313
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 05:35 EDT by Wei Liu
Modified: 2017-09-22 14:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-22 14:04:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Liu 2017-07-05 05:35:24 EDT
Description of problem:
There is error message in rhsm.log when install SAM cert

Version-Release number of selected component (if applicable):
SAM-1.4.1-RHEL-6-20141113.0
python-rhsm-1.19.9-1.el7.x86_64
python-rhsm-certificates-1.19.9-1.el7.x86_64
subscription-manager-1.19.21-1.el7.x86_64
subscription-manager-gui-1.19.21-1.el7.x86_64
subscription-manager-initial-setup-addon-1.19.21-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Install build rhel-7.4-rc-1.0(RHEL-7.4-20170630.1)

2.Insatll SAM cert

[root@localhost ~]# wget http://10.66.128.149/pub/candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm
--2017-07-05 17:13:55--  http://10.66.128.149/pub/candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm
Connecting to 10.66.128.149:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7061 (6.9K) [application/x-rpm]
Saving to: ‘candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm’

100%[======================================>] 7,061       --.-K/s   in 0s      

2017-07-05 17:13:55 (472 MB/s) - ‘candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm’ saved [7061/7061]

[root@localhost ~]# rpm -ivh candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:candlepin-cert-consumer-samserv.r################################# [100%]

3.Check the rhsm.log and find the error message

[root@localhost rhsm]# cat rhsm.log
2017-07-05 17:14:00,718 [INFO] rhsmd:2814:MainThread @rhsmd:263 - rhsmd started
2017-07-05 17:14:01,332 [ERROR] rhsmd:2814:MainThread @cache.py:128 - Unable to read cache: /var/lib/rhsm/cache/rhsm_icon.json
2017-07-05 17:14:01,332 [ERROR] rhsmd:2814:MainThread @cache.py:129 - [Errno 2] No such file or directory: '/var/lib/rhsm/cache/rhsm_icon.json'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/subscription_manager/cache.py", line 123, in _read_cache
    f = open(self.CACHE_FILE)
IOError: [Errno 2] No such file or directory: '/var/lib/rhsm/cache/rhsm_icon.json'
2017-07-05 17:14:06,669 [INFO] rhsmd:2833:MainThread @rhsmd:263 - rhsmd started
2017-07-05 17:14:06,893 [INFO] subscription-manager:2827:MainThread @managercli.py:518 - X-Correlation-ID: e2561c83c7234706bc01b6051b5fb9e7
2017-07-05 17:14:06,893 [INFO] subscription-manager:2827:MainThread @managercli.py:407 - Client Versions: {'python-rhsm': '1.19.9-1.el7', 'subscription-manager': '1.19.21-1.el7'}

Actual results:
AS step 3.


Expected results:
No error message append to the rhsm.log

Additional info:
Comment 1 Craig Donnelly 2017-09-22 14:04:57 EDT
Closing this out as a dupe, as its also completely unrelated to SAM.

*** This bug has been marked as a duplicate of bug 1448313 ***

Note You need to log in before you can comment on or make changes to this bug.