Bug 1467850 - SELinux is preventing gnome-shell from 'read' accesses on the lnk_file machine-id.
SELinux is preventing gnome-shell from 'read' accesses on the lnk_file machin...
Status: CLOSED DUPLICATE of bug 1467036
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:1f4eef88321bdcd9771118df527...
:
: 1468851 1470063 1470284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 06:36 EDT by newsletters
Modified: 2017-07-17 19:32 EDT (History)
36 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 08:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description newsletters 2017-07-05 06:36:59 EDT
Description of problem:
Nothing Fancy. Fedora Core 25 was just idling, with a couple of terimnals open, chrome, and Spotify
SELinux is preventing gnome-shell from 'read' accesses on the lnk_file machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gnome-shell should be allowed read access on the machine-id lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gnome-shell' --raw | audit2allow -M my-gnomeshell
# semodule -X 300 -i my-gnomeshell.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                machine-id [ lnk_file ]
Source                        gnome-shell
Source Path                   gnome-shell
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.18.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.8-200.fc25.x86_64 #1 SMP Thu
                              Jun 29 16:13:56 UTC 2017 x86_64 x86_64
Alert Count                   6
First Seen                    2017-07-05 08:57:10 CEST
Last Seen                     2017-07-05 11:04:20 CEST
Local ID                      337df28a-9bcb-4d08-9f52-ac649d73bcc5

Raw Audit Messages
type=AVC msg=audit(1499245460.967:264): avc:  denied  { read } for  pid=1695 comm="gnome-settings-" name="machine-id" dev="dm-1" ino=1048591 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: gnome-shell,xdm_t,system_dbusd_var_lib_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport

Potential duplicate: bug 1467036
Comment 1 Manu 2017-07-05 23:21:14 EDT
Description of problem:
Aparecio este error mientras renderizaba un video.

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 2 Mark Drobnak 2017-07-06 19:38:03 EDT
Description of problem:
Notification was there after I turned on my  laptop.

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 3 Jason Stevens 2017-07-06 20:22:24 EDT
Description of problem:
SELinux is preventing gnome-shell from 'read' accesses on the lnk_file /var/lib/dbus/machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gnome-shell should be allowed read access on the machine-id lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gnome-shell' --raw | audit2allow -M my-gnomeshell
# semodule -X 300 -i my-gnomeshell.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                /var/lib/dbus/machine-id [ lnk_file ]
Source                        gnome-shell
Source Path                   gnome-shell
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.18.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.8-200.fc25.x86_64 #1 SMP Thu
                              Jun 29 16:13:56 UTC 2017 x86_64 x86_64
Alert Count                   22
First Seen                    2017-07-05 15:49:01 CDT
Last Seen                     2017-07-06 16:58:21 CDT
Local ID                      410aebe9-9c3e-4ed2-b3fe-759eb0f00f3c

Raw Audit Messages
type=AVC msg=audit(1499378301.526:284): avc:  denied  { read } for  pid=1855 comm="gnome-settings-" name="machine-id" dev="dm-1" ino=1443388 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: gnome-shell,xdm_t,system_dbusd_var_lib_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 4 Pablo Ganuza 2017-07-07 14:51:11 EDT
Description of problem:
I locked the screen and after a while I wanted to log in again. Computer freezed when I provided the password for my user and hit Enter button. I could not switch to another tty with ctrl+alt+f[number]

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 5 glaucio.melo 2017-07-08 06:14:05 EDT
Description of problem:
An alert note from fedore showed up to me warning that gnome-shell is trying to read the machine-id file. I'm not sure this is related, but I did the latest OS fedora update a day before it.

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 6 Michael 2017-07-08 19:22:57 EDT
*** Bug 1468851 has been marked as a duplicate of this bug. ***
Comment 7 rahisul haque 2017-07-08 23:11:16 EDT
Description of problem:
I got this security alert from me fedora 25 work station.

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 8 Matt Castelein 2017-07-09 09:15:07 EDT
Description of problem:
I clicked on the low battery notification and this AVC popped up

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 9 jenkinsshubham 2017-07-10 23:20:27 EDT
Description of problem:
I don't know exactly.

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 10 amitbhagat784 2017-07-12 07:17:26 EDT
*** Bug 1470063 has been marked as a duplicate of this bug. ***
Comment 11 pmoody050 2017-07-12 12:06:25 EDT
*** Bug 1470284 has been marked as a duplicate of this bug. ***
Comment 12 goul 2017-07-12 20:30:51 EDT
Description of problem:
Greetings!
This bug started when i starte downloading torrents on my station.
/////////////////////////
*			*
*			*
*			*
\\\\\\\\\\\\\\\\\\\\\\\\\

Version-Release number of selected component:
selinux-policy-3.13.1-225.18.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.11.8-200.fc25.x86_64
type:           libreport
Comment 13 Daniel Walsh 2017-07-13 08:47:58 EDT

*** This bug has been marked as a duplicate of bug 1467036 ***

Note You need to log in before you can comment on or make changes to this bug.