Bug 1467867 - The "Add Node" button in the node registration dialog is not working
The "Add Node" button in the node registration dialog is not working
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-ui (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity urgent
: ---
: 12.0 (Pike)
Assigned To: Jiri Tomasek
Ola Pavlenko
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 07:26 EDT by Udi
Modified: 2017-09-12 10:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-12 10:18:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2017-07-05 07:26:11 EDT
Description of problem:
When clicking on "Add Node" - nothing happens in the dialog.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.1.1-0.20170627161345.68e8684.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Go to the Nodes page
2. Click on Register Nodes to open the node registration dialog
3. Click Add Node


Actual results:
No reaction.


Expected results:


Additional info:
There is an error in the console but I'm not sure if it's related to this bug because the same error appears in many other actions on the GUI (and this is the only action which really doesn't work when this error appears)...

logger.js:63 Error: Minified React error #31; visit http://facebook.github.io/react/docs/error-decoder.html?invariant=31&args[]=%5Bobject%20XMLHttpRequest%5D&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.(…)i.value @ logger.js:63(anonymous function) @ logger.js:150i.value @ logger.js:143t.(anonymous function) @ logger.js:111window.onerror @ logger.js:156

Note You need to log in before you can comment on or make changes to this bug.