Bug 1467887 - iommu platform support for ipxe
Summary: iommu platform support for ipxe
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipxe
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: jason wang
QA Contact: FuXiangChun
URL:
Whiteboard:
Depends On:
Blocks: 1481180
TreeView+ depends on / blocked
 
Reported: 2017-07-05 12:24 UTC by jason wang
Modified: 2018-04-10 16:43 UTC (History)
11 users (show)

Fixed In Version: ipxe-20170123-2.git4e85b27.el7
Doc Type: Bug Fix
Doc Text:
Previously, guest virtual machines that use the iPXE environment were not able to boot over a network if the Input/Output Memory Management Unit (IOMMU) mode was set for the virtio-net device. With this update, iPXE handles IOMMU setting correctly, and guests are able to boot properly in the described scenario.
Clone Of:
: 1481180 (view as bug list)
Environment:
Last Closed: 2018-04-10 16:42:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 16:43:25 UTC

Description jason wang 2017-07-05 12:24:41 UTC
Description of problem:

We need claim the support for VIRTIO_F_IOMMU_PLATFORM, otherwise ipxe won't work if iommu is enabled for virtio-net.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. enable iommu_platform for virtio-net
2. boot from network
3.

Actual results:

Can't get any nic in guest.

Expected results:

Works like a charm.

Additional info:

Comment 2 jason wang 2017-07-13 04:21:13 UTC
Patch accepted upstream.

Comment 6 Han Han 2017-08-10 09:08:31 UTC
(In reply to jason wang from comment #2)
> Patch accepted upstream.

Please provide the upstream patch link.

Comment 10 Miroslav Rezanina 2017-08-17 06:06:28 UTC
Fix included in ipxe-20170123-2.git4e85b27.el7

Comment 11 FuXiangChun 2017-08-24 08:49:02 UTC
Verified component version as below:

ipxe-roms-20170123-2.git4e85b27.el7.noarch
ipxe-roms-qemu-20170123-2.git4e85b27.el7.noarch
ipxe-bootimgs-20170123-2.git4e85b27.el7.noarch

3.10.0-704.el7.x86_64
qemu-kvm-rhev-2.9.0-16.el7.x86_64
seabios-1.10.2-3.el7.x86_64

steps:

1. Add "iommu=pt intel_iommu=on" to host kernel line

2. Add "intel_iommu=on" guest kernel line

3. qemu-kvm cmd:
/usr/libexec/qemu-kvm ....-device virtio-net-pci,netdev=hostnet1,id=net1,mac=52:54:00:7e:af:e6,iommu_platform=on,disable-modern=off,disable-legacy=on -netdev tap,id=hostnet1,vhost=on ....

Test result:

NIC works in guest.

Comment 13 FuXiangChun 2017-12-07 10:40:51 UTC
According to comment11, set this bug as verified status

Comment 16 errata-xmlrpc 2018-04-10 16:42:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918


Note You need to log in before you can comment on or make changes to this bug.