Bug 1467910 - NetworkManager PPTP plugin doesn't work
NetworkManager PPTP plugin doesn't work
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: NetworkManager-pptp (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 09:34 EDT by Pavel Roschin
Modified: 2018-01-27 10:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Roschin 2017-07-05 09:34:38 EDT
Description of problem:
NetworkManager PPTP plugin from EPEL repository doesn't work.

Version-Release number of selected component (if applicable):
NetworkManager-bluetooth-1.4.0-12.el7.x86_64
NetworkManager-1.4.0-12.el7.x86_64
NetworkManager-libnm-1.4.0-12.el7.x86_64
NetworkManager-team-1.4.0-12.el7.x86_64
NetworkManager-libreswan-gnome-1.2.4-1.el7.x86_64
NetworkManager-adsl-1.4.0-12.el7.x86_64
NetworkManager-wwan-1.4.0-12.el7.x86_64
NetworkManager-pptp-1.1.0-3.20150428git695d4f2.el7.x86_64
NetworkManager-tui-1.4.0-12.el7.x86_64
NetworkManager-pptp-gnome-1.1.0-3.20150428git695d4f2.el7.x86_64
NetworkManager-wifi-1.4.0-12.el7.x86_64
NetworkManager-libreswan-1.2.4-1.el7.x86_64
NetworkManager-glib-1.4.0-12.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install NetworkManager-pptp-gnome from EPEL
2. systemctl restart NetworkManager
3. nm-connection-editor -> Add

Actual results:
Message: vpn: (pptp,/etc/NetworkManager/VPN/nm-pptp-service.name) cannot load legacy-only plugin

Expected results:
PPTP in list of VPN connections.
Comment 1 Paulo Evangelista 2017-08-02 11:08:54 EDT
Same here. PPTP ins't showed in list of VPN connections.
Comment 2 thunder367 2017-11-05 08:09:39 EST
Same.
NetworkManager-pptp                         x86_64                         1:1.1.0-3.20150428git695d4f2.el7
NetworkManager                             x86_64                             1:1.8.0-11.el7_4
NetworkManager-pptp-gnome                       x86_64                       1:1.1.0-3.20150428git695d4f2.el7                         epel

It's critical for me. Please fix it.
Comment 3 Stamatis 2018-01-27 10:35:36 EST
I can confirm the same. Seems it's because its linked with the old libnm-util/libnm-glib and not with libnm. 

As a workaround I downloaded the latest source from gnome ( NetworkManager-pptp-1.2.4.tar.xz ) , compiled it manually and it's working fine.

Note You need to log in before you can comment on or make changes to this bug.