Bug 1467910 - NetworkManager PPTP plugin doesn't work
Summary: NetworkManager PPTP plugin doesn't work
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: NetworkManager-pptp   
(Show other bugs)
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-05 13:34 UTC by Pavel Roschin
Modified: 2018-11-05 03:23 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-pptp-1.2.8-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-11-05 03:23:36 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Roschin 2017-07-05 13:34:38 UTC
Description of problem:
NetworkManager PPTP plugin from EPEL repository doesn't work.

Version-Release number of selected component (if applicable):
NetworkManager-bluetooth-1.4.0-12.el7.x86_64
NetworkManager-1.4.0-12.el7.x86_64
NetworkManager-libnm-1.4.0-12.el7.x86_64
NetworkManager-team-1.4.0-12.el7.x86_64
NetworkManager-libreswan-gnome-1.2.4-1.el7.x86_64
NetworkManager-adsl-1.4.0-12.el7.x86_64
NetworkManager-wwan-1.4.0-12.el7.x86_64
NetworkManager-pptp-1.1.0-3.20150428git695d4f2.el7.x86_64
NetworkManager-tui-1.4.0-12.el7.x86_64
NetworkManager-pptp-gnome-1.1.0-3.20150428git695d4f2.el7.x86_64
NetworkManager-wifi-1.4.0-12.el7.x86_64
NetworkManager-libreswan-1.2.4-1.el7.x86_64
NetworkManager-glib-1.4.0-12.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install NetworkManager-pptp-gnome from EPEL
2. systemctl restart NetworkManager
3. nm-connection-editor -> Add

Actual results:
Message: vpn: (pptp,/etc/NetworkManager/VPN/nm-pptp-service.name) cannot load legacy-only plugin

Expected results:
PPTP in list of VPN connections.

Comment 1 Paulo Evangelista 2017-08-02 15:08:54 UTC
Same here. PPTP ins't showed in list of VPN connections.

Comment 2 thunder367 2017-11-05 13:09:39 UTC
Same.
NetworkManager-pptp                         x86_64                         1:1.1.0-3.20150428git695d4f2.el7
NetworkManager                             x86_64                             1:1.8.0-11.el7_4
NetworkManager-pptp-gnome                       x86_64                       1:1.1.0-3.20150428git695d4f2.el7                         epel

It's critical for me. Please fix it.

Comment 3 Stamatis 2018-01-27 15:35:36 UTC
I can confirm the same. Seems it's because its linked with the old libnm-util/libnm-glib and not with libnm. 

As a workaround I downloaded the latest source from gnome ( NetworkManager-pptp-1.2.4.tar.xz ) , compiled it manually and it's working fine.

Comment 4 Trevor Hemsley 2018-08-15 13:05:27 UTC
NetworkManager-pptp hasn't been updated in EPEL7 since 2015 and no longer functions with the current NetworkManager. I would suggest that it should be orphaned and removed if it's not going to get updated. It's currently useless as-is. As a VPN, pptp is pretty useless anyway.

Comment 5 Vinicius Trivinho 2018-10-03 13:40:24 UTC
It is critical for me too and I downloaded the latest source from gnome but can't get it working.

Comment 6 Fedora Update System 2018-10-04 10:01:43 UTC
NetworkManager-pptp-1.2.8-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-545d216655

Comment 7 Vinicius Trivinho 2018-10-04 12:51:42 UTC
It worked! Thanks!!

Comment 8 Fedora Update System 2018-10-05 18:47:03 UTC
NetworkManager-pptp-1.2.8-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-545d216655

Comment 9 Fedora Update System 2018-11-05 03:23:36 UTC
NetworkManager-pptp-1.2.8-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.