Bug 146799 - Quick title bar clicks in metacity drag the window
Quick title bar clicks in metacity drag the window
Status: CLOSED DUPLICATE of bug 146195
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: metacity (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Depends On:
  Show dependency treegraph
Reported: 2005-02-01 12:54 EST by Steve Atwell
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-09 16:38:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve Atwell 2005-02-01 12:54:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050107 Firefox/1.0

Description of problem:
The upclick of a quick mouse click on a title bar in metacity doesn't
seem to be recognized.  If you click quickly on a titlebar, it will
often be "stuck" to the mouse pointer and get dragged around until I
click again.  This seems to be related to bug 109915.  Going from
Update 3 to Update 4 fixed this on one system (2.4GHz Dell OptiPlex
GX260) but not another (2.8GHz Dell OptiPlex GX270).  On the 2.8GHz
system, if I try to click as quickly as possible, about 1/4-1/2 the
clicks fail this way.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run metacity, with or without GNOME.
2. Click very quickly on the title bar of any window.

Actual Results:  The window gets dragged around until you click the
mouse again.

Expected Results:  Should behave identically to a slower click.

Additional info:
Comment 1 Havoc Pennington 2005-02-01 16:02:35 EST
Right, we have one or two other reports of continued problems with
this in U4 in the support issue tracker. Current theory seems to be
that there may also be a kernel or X issue. There could also be a
lingering metacity bug.
Comment 2 Ray Strode [halfline] 2005-09-09 16:38:08 EDT
Hi Steve,

This should be resolved in RHEL3-U6

*** This bug has been marked as a duplicate of 146195 ***

Note You need to log in before you can comment on or make changes to this bug.