Bug 1468016 - Switch to host-model as default CPU (for virt-manager and virt-install)
Switch to host-model as default CPU (for virt-manager and virt-install)
Status: CLOSED DUPLICATE of bug 1055002
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 15:07 EDT by Adam Williamson
Modified: 2017-07-10 19:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-10 19:47:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-07-05 15:07:56 EDT
virtManager/config.py has this little stanza in `get_default_cpu_setting`, the method for returning the 'default' CPU model:

        if for_cpu and ret == CPU.SPECIAL_MODE_HOST_MODEL:
            # host-model has known issues, so use our 'copy cpu'
            # behavior until host-model does what we need
            ret = CPU.SPECIAL_MODE_HOST_COPY

I believe the 'known issues' referred to there are those documented in https://bugzilla.redhat.com/show_bug.cgi?id=870071 , which is closed from libvirt 3.2.0 onwards.

Perhaps this workaround should now be removed, or made conditional on libvirt < 3.2.0, at this point?

Note: I'll be opening a similar issue on Boxes, which acts similarly.
Comment 1 Cole Robinson 2017-07-10 19:47:47 EDT

*** This bug has been marked as a duplicate of bug 1055002 ***

Note You need to log in before you can comment on or make changes to this bug.