Bug 1468020 - [RFE][OtherQA] Manila IPv6 in access rule enablement with NetApp back end
Summary: [RFE][OtherQA] Manila IPv6 in access rule enablement with NetApp back end
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Tom Barron
QA Contact: Dustin Schoenbrun
Don Domingo
URL:
Whiteboard:
Depends On:
Blocks: 1484502 1523864
TreeView+ depends on / blocked
 
Reported: 2017-07-05 19:14 UTC by Chris Fields
Modified: 2019-04-03 17:08 UTC (History)
17 users (show)

Fixed In Version: openstack-manila-6.0.0-0.20180122210259.4adbf82.el7ost openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost puppet-manila-12.2.0-0.20180119090000.4d9b494.el7ost
Doc Type: Release Note
Doc Text:
The Shared File System service (manila) now provides IPv6 access rule support with NetApp ONTAP cDOT driver, which lets you use manila with IPv6 environments. As a result, the Shared File System service now supports exporting shares backed by NetApp ONTAP back ends over IPv6 networks. Access to the exported shares is controlled by IPv6 client addresses.
Clone Of:
: 1484502 1509669 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:31:39 UTC
Target Upstream Version:
tbarron: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 312321 None master: MERGED manila: Enable IPv6 in manila(allow access) (Ica242007e77a7e21b2151e5fc32401b501d961b2) 2018-02-07 14:12:26 UTC
OpenStack gerrit 406776 None master: MERGED manila: Enable IPv6 in manila(network plugins and drivers) (I96d3389262e9829b8b4344870cdf5c76abd22828) 2018-02-07 14:12:20 UTC
OpenStack gerrit 506947 None master: MERGED manila: Allow IPv6 gateways for the default route (Ia26d55368aa5a08da7e0941170ed2ac23db307d4) 2018-02-07 14:12:12 UTC
OpenStack gerrit 506948 None master: MERGED manila: Advertise IPv6 support in the NetApp driver (I84437b140e2a9561cc4092683209800101f45815) 2018-02-07 14:12:05 UTC
OpenStack gerrit 516449 None master: MERGED puppet-manila: Add support for address family parameters (Ic7e5b5351e429755ba48613ab89d1b7e7d6e2d34) 2018-02-07 14:11:59 UTC
OpenStack gerrit 522229 None master: MERGED tripleo-heat-templates: Manila network plugin address family support (Ia895d7190f0fb8e97c87b3178461d9fc26393b9b) 2018-02-07 14:11:53 UTC
OpenStack gerrit 524236 None master: MERGED manila: Simplify the way drivers report support for ipv6 (I382767918a65b91e99ac1e604304ad01fac332e6) 2018-02-07 14:11:46 UTC
Red Hat Product Errata RHEA-2018:2086 normal SHIPPED_LIVE Red Hat OpenStack Platform 13.0 Enhancement Advisory 2018-06-28 19:51:39 UTC

Description Chris Fields 2017-07-05 19:14:24 UTC
Description of problem:

IPv6 is not currently supported in Manila in any release.  See these specs: 
https://specs.openstack.org/openstack/manila-specs/specs/ocata/manila-ipv6.html
https://specs.openstack.org/openstack/manila-specs/specs/pike/manila-ipv6.html

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. try this: 'manila access-allow <share name> ip "<ipv6 address>"
2.
3.

Actual results:
Error

Expected results:
Allow access to named share from the named ipv6 address

Additional info:

Comment 24 Tom Barron 2017-12-06 16:40:57 UTC
Moving this back to ON_DEV since reviews 522229 and 524236 have not yet merged upstream.

Comment 25 Tom Barron 2017-12-07 12:38:02 UTC
524236 has merged upstream but 522229 is still in review.

Comment 27 Tom Barron 2017-12-21 10:01:41 UTC
Final outstanding review 522229 has merged upstream so I am moving this to POST.

Comment 39 Jon Schlueter 2018-06-22 16:20:54 UTC
The content for this fix is included in OSP 13 RC which is available on the Red Hat OpenStack Platform beta channels currently.  Any efforts to verify that these bugs have been fixed would be appreciated.

Comment 41 errata-xmlrpc 2018-06-27 13:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.