Bug 1468025 - Heat ScaleIO/Cinder Puppet module deploys invalid Cinder driver by default
Heat ScaleIO/Cinder Puppet module deploys invalid Cinder driver by default
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-cinder (Show other bugs)
11.0 (Ocata)
All Linux
medium Severity medium
: z4
: 11.0 (Ocata)
Assigned To: Alan Bishop
Avi Avraham
: OtherQA, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 15:36 EDT by Siggy Sigwald
Modified: 2018-02-13 11:31 EST (History)
6 users (show)

See Also:
Fixed In Version: puppet-cinder-10.3.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the ScaleIO cinder driver code had been relocated in the cinder code tree, however, the puppet code responsible for configuring the driver had not been updated to refer to the driver in its new location. Consequently, Puppet would misconfigure the ScaleIO driver by using an obsolete reference to the driver location. The driver still continued to function because cinder has a built-in mechanism for mapping references to old driver locations to their new location. With this update, the `puppet-cinder` code has been updated to reference the ScaleIO driver in its new location.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-13 11:31:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1718986 None None None 2017-09-22 13:41 EDT
OpenStack gerrit 506741 None None None 2017-09-22 14:19 EDT
OpenStack gerrit 507530 None None None 2017-09-26 09:13 EDT

  None (edit)
Description Siggy Sigwald 2017-07-05 15:36:12 EDT
Description of problem:
In RHOSP11 the bundled Dell EMC ScaleIO module used for heat deployments uses an old driver name. This driver file does not exist anymore -- this makes the entire Cinder backend deployment using the provided template not work.

To fix this, please make the following changes. 
In this file: /usr/share/openstack-puppet/modules/cinder/manifests/backend/scaleio.pp
The volume_driver variable must be changed from:
cinder.volume.drivers.emc.scaleio.ScaleIODriver
to
cinder.volume.drivers.dell_emc.scaleio.driver.ScaleIODriver

The correctly named driver file comes with RHOSP11, the Puppet module just specifies the incorrect legacy file that has not existed for a while already.

How reproducible:
This happens evey time when using the ScaleIO Cinder backend.
Comment 1 Eric Harney 2017-07-19 09:38:24 EDT
We should fix this, but things should work with the old path, since the Cinder volume manager has a compat layer that maps the old path to the new path:

https://git.openstack.org/cgit/openstack/cinder/tree/cinder/volume/manager.py?h=10.0.3#n158
Comment 2 Alan Bishop 2017-09-25 12:19:58 EDT
Patch has been accepted upstream, and I'm backporting to stable/pike, and then stable/ocata.
Comment 3 Alan Bishop 2017-09-26 09:13:23 EDT
Patch has been accepted on stable/pike, and proposed to stable/ocata.
Comment 4 Alan Bishop 2017-10-13 12:38:02 EDT
It looks like the fix will be picked up during the import from RDO for 11z4.
Comment 7 Tzach Shefi 2018-01-29 06:58:22 EST
Set OtherQA, 
Don't have ScaleIO system to actually run any Cinder functions over. 

I did however verify that on this file:
/usr/share/openstack-puppet/modules/cinder/manifests/backend/scaleio.pp

Volume_driver variable has been changed to correct one:
cinder.volume.drivers.dell_emc.scaleio.driver.ScaleIODriver
Comment 10 errata-xmlrpc 2018-02-13 11:31:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0310

Note You need to log in before you can comment on or make changes to this bug.