Bug 1468031 - rgw: shadow objects are sometimes not removed (after copy)
rgw: shadow objects are sometimes not removed (after copy)
Status: CLOSED DUPLICATE of bug 1505504
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.3
All All
high Severity high
: rc
: 3.0
Assigned To: Yehuda Sadeh
Tejas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 15:47 EDT by Matt Benjamin (redhat)
Modified: 2017-11-01 14:33 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.2.1-35.el7cp Ubuntu: ceph_12.2.1-37redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-01 14:33:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 20234 None None None 2017-07-05 15:47 EDT

  None (edit)
Description Matt Benjamin (redhat) 2017-07-05 15:47:18 EDT
Description of problem:
after copying an object, then deleting the copy and finally deleting the original object, the associated shadow objects to not get deleted because there is a mismatch in the tags involved.

Version-Release number of selected component (if applicable):
2.3

(reproducer instructions and discussion in the upstream tracker issue)

Note You need to log in before you can comment on or make changes to this bug.