Bug 1468087 - SELinux is preventing ibus-engine-sim from 'read' accesses on the lnk_file machine-id.
SELinux is preventing ibus-engine-sim from 'read' accesses on the lnk_file ma...
Status: CLOSED DUPLICATE of bug 1467036
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:a7378956a83e280570c99b43e8d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 22:26 EDT by Vassilis Kontodimas
Modified: 2017-07-25 08:48 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 08:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vassilis Kontodimas 2017-07-05 22:26:19 EDT
Description of problem:
I took my Sony laptop out of sleep mode when I opened up the lid and pressed a key. That's when I encountered the bug.

Also, worthwhile to mention that when I put the laptop to sleep (and reactivated it), the Spotify app was running in the background. It did not crash.
SELinux is preventing ibus-engine-sim from 'read' accesses on the lnk_file machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ibus-engine-sim should be allowed read access on the machine-id lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ibus-engine-sim' --raw | audit2allow -M my-ibusenginesim
# semodule -X 300 -i my-ibusenginesim.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                machine-id [ lnk_file ]
Source                        ibus-engine-sim
Source Path                   ibus-engine-sim
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-259.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.8-300.fc26.x86_64 #1 SMP Thu
                              Jun 29 20:09:48 UTC 2017 x86_64 x86_64
Alert Count                   11
First Seen                    2017-07-05 23:49:35 EEST
Last Seen                     2017-07-06 03:39:28 EEST
Local ID                      48a584d9-3e26-4a41-ad8c-74e0a94d6c07

Raw Audit Messages
type=AVC msg=audit(1499301568.779:437): avc:  denied  { read } for  pid=1339 comm="gsd-power" name="machine-id" dev="dm-0" ino=396305 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: ibus-engine-sim,xdm_t,system_dbusd_var_lib_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64
type:           libreport
Comment 1 Vassilis Kontodimas 2017-07-06 14:09:36 EDT
Description of problem:
Actually, this happened -again- after my laptop "woke up" from the lock screen. That's when I found this message.
In the background, Firefox, Chrome and Evolution was running. Basically sitting idle on Facebook and Wordpress (alongside the Fedora default site).

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64
type:           libreport
Comment 2 Vassilis Kontodimas 2017-07-08 00:02:24 EDT
Description of problem:
This event occured twice. Once after the OS update reboot and once the moment I installed Powerline per Fedora's start page.

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.8-300.fc26.x86_64
type:           libreport
Comment 3 Bojan Jovanovic 2017-07-25 06:29:28 EDT
Description of problem:
Fujitsu laptop on lid open after sleep. Background applications: Firefox, tilix.

SELinux is preventing ibus-engine-sim from read access on the lnk_file /var/lib/dbus/machine-id.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ibus-engine-sim should be allowed read access on the machine-id lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ibus-engine-sim' --raw | audit2allow -M my-ibusenginesim
# semodule -X 300 -i my-ibusenginesim.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
Target Objects                /var/lib/dbus/machine-id [ lnk_file ]
Source                        ibus-engine-sim
Source Path                   ibus-engine-sim
Port                          <Unknown>
Host                          e754.snefu.lnet
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-260.1.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     e754.snefu.lnet
Platform                      Linux e754.snefu.lnet 4.11.11-300.fc26.x86_64 #1
                              SMP Mon Jul 17 16:32:11 UTC 2017 x86_64 x86_64
Alert Count                   43
First Seen                    2017-07-14 14:59:39 CEST
Last Seen                     2017-07-24 16:49:01 CEST
Local ID                      f5020289-a415-4991-817f-4d79fd982db1

Raw Audit Messages
type=AVC msg=audit(1500907741.431:372): avc:  denied  { read } for  pid=1218 comm="gsd-power" name="machine-id" dev="sdb3" ino=67705142 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=lnk_file permissive=0


Hash: ibus-engine-sim,xdm_t,system_dbusd_var_lib_t,lnk_file,read


Everything else work as expected.
Comment 4 Daniel Walsh 2017-07-25 08:48:49 EDT

*** This bug has been marked as a duplicate of bug 1467036 ***

Note You need to log in before you can comment on or make changes to this bug.