Bug 1468109 - provide a heketi image with auto_create_block_hosting_volume enabled by default
provide a heketi image with auto_create_block_hosting_volume enabled by default
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity urgent
: ---
: CNS 3.6
Assigned To: Mohamed Ashiq
krishnaram Karthick
: TestBlocker
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-06 01:58 EDT by krishnaram Karthick
Modified: 2017-10-11 03:07 EDT (History)
6 users (show)

See Also:
Fixed In Version: heketi-5.0.0-4 rhgs-volmanager-docker-3.3.0-6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:07:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnaram Karthick 2017-07-06 01:58:38 EDT
Description of problem:
With the rhgs3/rhgs-volmanager-rhel7:3.3.0-3 image, auto_create_block_hosting_volume is not enabled by default. As a result, block devices can't be created.

Block device create fails

[root@dhcp47-10 ~]# heketi-cli blockvolume create --size 10
Error: Block Hosting Volume Creation is Disabled. Create a Block hosting volume and try again.

Please provide a new heketi image with auto_create_block_hosting_volume enabled by default.


Version-Release number of selected component (if applicable):
heketi image - rhgs3/rhgs-volmanager-rhel7:3.3.0-3

How reproducible:
Always

Steps to Reproduce:
1. Try to create a block device with the above mentioned image

Actual results:
block vol creation fails

Expected results:
block vol creation should succeed

Additional info:
Comment 8 errata-xmlrpc 2017-10-11 03:07:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2879

Note You need to log in before you can comment on or make changes to this bug.