This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1468126 - disperse seek does not correctly handle the end of file
disperse seek does not correctly handle the end of file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On: 1449348
Blocks: 1468118
  Show dependency treegraph
 
Reported: 2017-07-06 02:36 EDT by Pranith Kumar K
Modified: 2017-08-21 09:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.10.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1449348
Environment:
Last Closed: 2017-08-21 04:17:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-07-06 02:36:14 EDT
+++ This bug was initially created as a clone of Bug #1449348 +++

Description of problem:

A seek with SEEK_HOLE can return an offset bigger than the file size. Additionally some offsets beyond the file size do return a valid answer instead of ENXIO as they should.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-05-09 13:43:17 EDT ---

REVIEW: https://review.gluster.org/17228 (cluster/ec: correctly handle end of file for seek) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Worker Ant on 2017-05-09 14:12:33 EDT ---

REVIEW: https://review.gluster.org/17228 (cluster/ec: correctly handle end of file for seek) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Worker Ant on 2017-05-11 03:24:14 EDT ---

REVIEW: https://review.gluster.org/17228 (cluster/ec: correctly handle end of file for seek) posted (#3) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Worker Ant on 2017-07-06 02:17:48 EDT ---

COMMIT: https://review.gluster.org/17228 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit eb96dd45f8e583c6bad84bf32ca17e2bb01dd38f
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue May 9 19:40:21 2017 +0200

    cluster/ec: correctly handle end of file for seek
    
    When a SEEK_HOLE was issued near to the end of file, sometimes an
    offset beyond the end of file was returned. Another problem was that
    using some offsets greater than the end of file returned successfully
    instead of failing with ENXIO.
    
    Change-Id: I238d2884ba02fd19a78116b0f8f8e8d6338fb3f5
    BUG: 1449348
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: https://review.gluster.org/17228
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 1 Worker Ant 2017-07-06 02:37:23 EDT
REVIEW: https://review.gluster.org/17711 (cluster/ec: correctly handle end of file for seek) posted (#1) for review on release-3.10 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-07-07 03:46:46 EDT
COMMIT: https://review.gluster.org/17711 committed in release-3.10 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 0f725500f50f386a19e33b077c7590d75bb276d8
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue May 9 19:40:21 2017 +0200

    cluster/ec: correctly handle end of file for seek
    
    When a SEEK_HOLE was issued near to the end of file, sometimes an
    offset beyond the end of file was returned. Another problem was that
    using some offsets greater than the end of file returned successfully
    instead of failing with ENXIO.
    
     >Change-Id: I238d2884ba02fd19a78116b0f8f8e8d6338fb3f5
     >BUG: 1449348
     >Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
     >Reviewed-on: https://review.gluster.org/17228
     >Smoke: Gluster Build System <jenkins@build.gluster.org>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
     >Reviewed-by: Amar Tumballi <amarts@redhat.com>
     >Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
     >(cherry picked from commit eb96dd45f8e583c6bad84bf32ca17e2bb01dd38f)
    
    Change-Id: I238d2884ba02fd19a78116b0f8f8e8d6338fb3f5
    BUG: 1468126
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: https://review.gluster.org/17711
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Shyamsundar 2017-08-21 09:40:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.5, please open a new bug report.

glusterfs-3.10.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-August/000079.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.