Bug 1468128 - script to send unsent mail stops on any bad message
script to send unsent mail stops on any bad message
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks: 1285621
  Show dependency treegraph
 
Reported: 2017-07-06 02:54 EDT by Jeff Fearn
Modified: 2017-07-13 23:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0.3-rh31
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 23:07:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2017-07-06 02:54:34 EDT
Description of problem:
The script backing the cron job to send unsent mail terminates if a bad email is encountered.

./contrib/sendunsentbugmail.pl

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Easy

Steps to Reproduce:
1. run the script

Actual results:
It will die because there are bad change sets in the DB.

Expected results:
All pending email is sent.

Additional info:
It should eval the call to Bugzilla::BugMail::Send and blurt out a message if it catches an error.
Comment 3 Jeff Fearn 2017-07-12 19:03:48 EDT
Sending mail for bug 934000...
        blew up, skipping because: Invalid parameter passed to Bugzilla::Bug::new_from_list: It must be
numeric.
Comment 4 Rony Gong 2017-07-13 02:33:17 EDT
@Jfearn, it work smoothly in QE server except with killer, Do you think it is a problem?

Sending mail for bug 1104574...
3 mails sent.
Took 1 seconds.

Sending mail for bug 1104598...
Killed
You have new mail in /var/spool/mail/root


Then I rerun this script, it could send out all email smoothly.
Comment 5 Jeff Fearn 2017-07-13 19:52:53 EDT
Yeah that should be OK.

Note You need to log in before you can comment on or make changes to this bug.