Bug 1468172 - [GSS](6.4.z]) SOAP - JAXB validation - fault when adding additional elements
[GSS](6.4.z]) SOAP - JAXB validation - fault when adding additional elements
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.4.9
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Peter Palaga
Peter Mackay
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 03:26 EDT by Francesco Marchioni
Modified: 2017-07-14 09:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 14:00:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test Web service (185 bytes, text/plain)
2017-07-12 07:16 EDT, Francesco Marchioni
no flags Details
SOAP input message to test the Web service (895 bytes, text/plain)
2017-07-12 07:21 EDT, Francesco Marchioni
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEAP-11984 Major Resolved [GSS] (EAP 7.1.z) SOAP - JAXB validation - fault when adding additional elements 2017-11-10 07:20 EST
Red Hat Knowledge Base (Solution) 3114701 None None None 2017-07-14 09:24 EDT

  None (edit)
Description Francesco Marchioni 2017-07-06 03:26:16 EDT
Description of problem:
When sending a SOAP request with additional elements, it results in a Fault reporting an Unmarshalling Error because of unexpected element. This causes compatibility issues for applications migrated from EAP 5, where additional SOAP elements are ignored. 

Version-Release number of selected component (if applicable):
6.4.z

How reproducible:

Example request:
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:wor="http://ws.bitmarck-software.de/framework/workflow/WorkflowBusinessWS">
   <soap:Header/>
   <soap:Body>
      <wor:setActivityStatus>
         <ActivityInstanceOid>3</ActivityInstanceOid>
         
         <MyTest>Hugo</MyTest>
         
      </wor:setActivityStatus>
   </soap:Body>
</soap:Envelope>

The element MyTest is additional and not part of WSDL.


Additional info:
Related case: 01743954
Comment 2 Francesco Marchioni 2017-07-12 07:15:27 EDT
Ok, I'm attaching the Webservice used to test which is anyway a minimal HelloWorld web service.
I'm also attaching the SOAP request and response.
Comment 3 Francesco Marchioni 2017-07-12 07:16 EDT
Created attachment 1296877 [details]
Test Web service
Comment 4 Francesco Marchioni 2017-07-12 07:21 EDT
Created attachment 1296879 [details]
SOAP input message to test the Web service
Comment 5 Peter Palaga 2017-07-13 09:30:20 EDT
I prepared a workaround based on ValidationEventHandler that ignores just the unexpected elements: https://github.com/ppalaga/JBEAP-11984-jaxb-addional-elems

The workaround is all we can offer. Setting dev_nack because we are not obligated to keep 100% backwards compatibility between major versions. Moreover, it is quite late to ask for this late phase of EAP 6 life cycle.
Comment 6 Brad Maxwell 2017-07-13 14:00:58 EDT
Closing as per previous comment

Note You need to log in before you can comment on or make changes to this bug.