Bug 1468274 - [RFE] Allow supplying MAC address to VMs created via Satellite6
Summary: [RFE] Allow supplying MAC address to VMs created via Satellite6
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.2.9
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-06 14:12 UTC by Mihir Lele
Modified: 2019-08-12 16:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-28 19:35:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mihir Lele 2017-07-06 14:12:43 UTC
Description of problem:

Satellite6 does not honour the mac address specified for provisioning via compute-resource

Version-Release number of selected component (if applicable): 6.2.9


How reproducible:  Always


Steps to Reproduce:

A) Through hammer:

1) hammer host create --hostgroup rhev --name host4 --mac 52:54:00:e4:15:26 --managed true --build true  --location Pune --organization-id 1  --enabled true --compute-profile rhev --compute-resource rhevm

B) Through api:

curl -H "Accept:application/json,version=2"        -H "Content-Type:application/json" -X POST -u admin:redhat        -k -d "{\"host\":{\"organization_id\":1,\"enabled\":1,\"build\":1,\"hostgroup_id\":2,\"compute_profile_name\":\"rhev\",\"compute_resource_name\":\"rhevm\",\"owner_id\":null,\"interfaces_attributes\": [ {\"provision\":1,\"domain_id\":1,\"mac\":\"00:50:56:91:7c:41\",\"primary\":1,\"type\":\"Nic::Managed\",\"ip\":\"192.168.100.99\",\"managed\":1,\"subnet_id\":1} ],\"name\":\"test123\",\"managed\":1,\"location_id\":2,\"owner_type\":\"User\",\"overwrite\":0}}"        https://satellite.example.com/api/hosts

Actual results:

Vm gets populated with a different MAC address.

Expected results:

VM should be built with same MAC address as provided on hammer or api.

Additional info:

1) I am using rhevm 4.0. 
2) This issue is also observed at the customer end where vmware is being used.
3) This works as expected when provisioned through webui

Comment 1 Lukas Zapletal 2017-07-21 14:02:40 UTC
This is not supported, creating VM via Satellite6 always generates random MAC address.

Comment 3 Lukas Zapletal 2018-02-05 11:11:26 UTC
Just quick update - we don't see this as bug, virtualization/cloud workflow is based on fact that compute resource generates MAC address and Satellite reads that. This RFE is on our backlog, no plans for now.

Comment 4 Lukáš Hellebrandt 2018-07-27 10:42:04 UTC
I can also reproduce this in Sat 6.4 using WebUI, using both API v3 and v4.

Comment 6 Bryan Kearney 2019-02-07 12:09:29 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 7 Bryan Kearney 2019-02-28 19:35:06 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.