Bug 1468290 - Pike sriov passing wrong argument for the passthrough whitelist
Pike sriov passing wrong argument for the passthrough whitelist
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-nova (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
medium Severity high
: Upstream M3
: 12.0 (Pike)
Assigned To: RHOS Maint
awaugama
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 11:13 EDT by Maxim Babushkin
Modified: 2018-02-05 14:10 EST (History)
15 users (show)

See Also:
Fixed In Version: puppet-nova-11.2.0-0.20170714191600.ff92413.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:39:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 481003 None None None 2017-07-06 12:11 EDT

  None (edit)
Description Maxim Babushkin 2017-07-06 11:13:29 EDT
Description of problem:
During the deployment of sriov on Pike, passthrough_whitelist does not passing correctly to nova.conf

Version-Release number of selected component (if applicable):
Pike 12

How reproducible:
Provide the following parameters within the sriov heat templates

NovaPCIPassthrough:
    - devname: "p5p1"
      physical_network: "sriov1"
    - devname: "p5p2"
      physical_network: "sriov2"

Actual results:
pci_passthrough_whitelist=[{"devname": "p5p1", "physical_network": "sriov1"}, {"devname": "p5p2", "physical_network": "sriov2"}]

Expected results:
passthrough_whitelist=[{"devname": "p5p1", "physical_network": "sriov1"}, {"devname": "p5p2", "physical_network": "sriov2"}]
Comment 5 errata-xmlrpc 2017-12-13 16:39:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.