Bug 1468309 - [3.6] Hawkular Metrics cannot handle connecting to the Kubernetes Master when the ca.crt contains multiple certificates.
[3.6] Hawkular Metrics cannot handle connecting to the Kubernetes Master when...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metrics (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Matt Wringe
Junqi Zhao
:
Depends On: 1479930 1447463 1461635 1468308
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 12:05 EDT by Matt Wringe
Modified: 2017-08-16 15 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1468308
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
metrics diagram could be viewed form web console (113.22 KB, image/png)
2017-07-06 21:37 EDT, Junqi Zhao
no flags Details

  None (edit)
Comment 4 Junqi Zhao 2017-07-06 21:37:11 EDT
Verify step is the same as 
https://bugzilla.redhat.com/show_bug.cgi?id=1447463#c64

Verification steps:
1. Add the example certificate before and after /etc/origin/master/ca-bundle.crt.
2. Restart server and deploy metrics 3.6.0 by using images from brew registry.
3. oc rsh ${HAWKULAR_METRICS_PODS};
   cat /var/run/secrets/kubernetes.io/serviceaccount/ca.crt

/var/run/secrets/kubernetes.io/serviceaccount/ca.crt is the same with /etc/origin/master/ca-bundle.crt.

4. Login web console, metrics can  be viewed, see the attached web UI snapshot

Testing env:
# openshift version
openshift v3.6.133
kubernetes v1.6.1+5115d708d7
etcd 3.2.1

Imags from brew registry
metrics-hawkular-metrics   v3.6                f6bec160916c        2 hours ago         1.293 GB
metrics-cassandra          v3.6                5cf7216bc89c        5 hours ago         573.2 MB
metrics-heapster           v3.6                a4b52c5e2110        18 hours ago        274.4 MB
Comment 5 Junqi Zhao 2017-07-06 21:37 EDT
Created attachment 1295126 [details]
metrics diagram could be viewed form web console
Comment 7 Junqi Zhao 2017-07-12 19:28:23 EDT
This is already verified, see Comment 4
Comment 9 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.