Bug 146840 - Need to fix XLIFF formatting
Need to fix XLIFF formatting
Status: CLOSED NEXTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2005-02-01 18:40 EST by Mike McCune
Modified: 2007-04-18 13:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 15:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2005-02-01 18:40:57 EST
> The one remaining thing is formatting. Some of the source didn't show
> properly, since xliff generally uses the format as is. In other words,
> if there is a newline within source tags, it is treated as a newline, if
> there is a tabulator, it is treated as a tabulator. If there are
> tabulators added, for example, in order to indent a line according to
> file layout, then these tabulators are added to the actual text, and the
> resulting output appears to have a bad format.


Ah, so we may need to remove the indenting from the file:

<trans-unit id="login.jsp.body1">
    <source>Red Hat Network is a complete systems management
        platform for Linux. It's built on open standards and
        uses a simple, Internet-based graphical interface. It
         also features a modular design--as networks grow,
            administrators
        can add enhanced capabilities for system updates,
        management, and monitoring of their entire
        infrastructure.</source>
</trans-unit>

would need to be:

<trans-unit id="login.jsp.body1">
    <source>Red Hat Network is a complete systems management
platform for Linux. It's built on open standards and uses a
simple, Internet-based graphical interface. It also
features a modular design--as networks grow, administrators
can add enhanced capabilities for system updates,
management, and monitoring of their entire
infrastructure.</source>
</trans-unit>

Actually, now that I think about that, at my last job we had to do
exactly that, because the tabs/spaces were included in the value of
the element which isn't desired.  If this isn't what you are talking
about, let me know.
Comment 1 Mike McCune 2005-02-10 15:13:55 EST
adding hours worked

Note You need to log in before you can comment on or make changes to this bug.