Bug 146841 - RHEL 4 U2: kernel panic when passing the 'nosmp' option to the x86_64 SMP kernel
RHEL 4 U2: kernel panic when passing the 'nosmp' option to the x86_64 SMP kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks: 170416
  Show dependency treegraph
 
Reported: 2005-02-01 19:13 EST by Amit Bhutani
Modified: 2013-08-05 21:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHEL4-U4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 16:19:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console trace of bootup and panic (31.87 KB, text/plain)
2005-02-01 19:13 EST, Amit Bhutani
no flags Details

  None (edit)
Description Amit Bhutani 2005-02-01 19:13:07 EST
Description of problem:
Passing the 'nosmp' option to a SMP enabled kernel causes a kernel 
panic.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-5.EL.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 4 x86_64 official RC1 on a SC1420
2. When grub menu is displayed, pick the smp kernel and edit the 
command line options to add 'nosmp' at the end of the kernel line
3. Allow the system to boot
  
Actual results:
kernel panic

Expected results:
System boots normally

Additional info:
I have not tried this on with the x86 arch yet.
Comment 1 Amit Bhutani 2005-02-01 19:13:58 EST
Created attachment 110536 [details]
serial console trace of bootup and panic
Comment 2 Susan Denham 2005-02-08 12:49:37 EST
Per Dell weekly meeting (Dale), this is deferred to U2.
Comment 10 Andrew 2005-11-14 11:10:55 EST
On dual Opteron hardware, booting the 32-bit Fedora Core 4 2.6.14-1.1637_FC4smp
Linux kernel with "nosmp" results in a similar problem.  After "OK, booting the
kernel" the system stops after repeating 7 times the message "IOAPIC[0]: Invalid
reference to IRQ 0".
Comment 13 Jim Paradis 2006-07-13 16:19:21 EDT
The kernel panic was fixed in U4 as a result of the fixes for Bug 174627 and Bug
176612.  That said, some systems still may not work with "nosmp" because it also
disables the IO APIC (See Comment 10).  The workaround for this is to use the
"noapic" flag along with "nosmp".  This is a known issue upstream as well.

Closing as CURRENTRELEASE for having fixed the panic.

Note You need to log in before you can comment on or make changes to this bug.