Bug 1468428 - All heketi command fails with error 'Failed to get list of pods'
All heketi command fails with error 'Failed to get list of pods'
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-volmanager-container (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: CNS 3.6
Assigned To: Mohamed Ashiq
krishnaram Karthick
: TestBlocker
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-07 00:43 EDT by krishnaram Karthick
Modified: 2017-10-11 03:07 EDT (History)
8 users (show)

See Also:
Fixed In Version: rhgs-volmanager-docker-3.3.0-6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:07:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2879 normal SHIPPED_LIVE heketi bug fix and enhancement update 2017-10-11 07:07:06 EDT

  None (edit)
Description krishnaram Karthick 2017-07-07 00:43:23 EDT
Description of problem:
heketi device add fails with the following error

# heketi-cli device add  --name=/dev/sdg --node=93250f0fc54117eb73fb30aefe5f6e54
Error: Failed to get list of pods


[negroni] Started POST /devices
[heketi] INFO 2017/07/07 04:33:25 Adding device /dev/sdg to node 93250f0fc54117eb73fb30aefe5f6e54
[negroni] Completed 202 Accepted in 344.896022ms
[asynchttp] INFO 2017/07/07 04:33:25 asynchttp.go:125: Started job 9cb56f03d04a56c7f09d8303fef30c22
[negroni] Started GET /queue/9cb56f03d04a56c7f09d8303fef30c22
[negroni] Completed 200 OK in 51.425µs
[kubeexec] ERROR 2017/07/07 04:33:25 /src/github.com/heketi/heketi/executors/kubeexec/kubeexec.go:302: User "system:serviceaccount:storage-project:heketi-service-account" cannot list pods in project "OpenShift project or Kubernetes namespace"
[kubeexec] ERROR 2017/07/07 04:33:25 /src/github.com/heketi/heketi/executors/kubeexec/kubeexec.go:303: Failed to get list of pods
[asynchttp] INFO 2017/07/07 04:33:25 asynchttp.go:129: Completed job 9cb56f03d04a56c7f09d8303fef30c22 in 148.686243ms
[negroni] Started GET /queue/9cb56f03d04a56c7f09d8303fef30c22


Version-Release number of selected component (if applicable):
rhgs3/rhgs-volmanager-rhel7:3.3.0-5
heketi-client-5.0.0-4.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. With the above mentioned version of cns, try to add device


Actual results:
device add fails

Expected results:
device add should succeed

Additional info:
Comment 2 krishnaram Karthick 2017-07-07 01:13:14 EDT
Well, all the heketi-cli command fails!

#heketi-cli blockvolume create --size=10
Error: Failed to get list of pods
Comment 4 Mohamed Ashiq 2017-07-07 06:57:16 EDT
Issues looks like in the heketi image. 
Thanks karthick for all the support on testing this issues and finding the RC.
Comment 9 krishnaram Karthick 2017-07-11 07:58:41 EDT
This issue is not seen anymore with heketi image rhgs-volmanager-docker-3.3.0-6

Moving the bug to verified.
Comment 10 errata-xmlrpc 2017-10-11 03:07:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2879

Note You need to log in before you can comment on or make changes to this bug.