Bug 1468431 - Zabbix agent fails to start due to being unable to disable coredumps
Summary: Zabbix agent fails to start due to being unable to disable coredumps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-07 05:11 UTC by Mark Keir
Modified: 2018-10-30 10:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:00:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1323518 None CLOSED Zabbix agent fails to start due to being unable to disable coredumps 2018-11-15 20:21:11 UTC
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:02:09 UTC

Description Mark Keir 2017-07-07 05:11:31 UTC
Description of problem:
Zabbix agent starts, then exits.  The log captured is:

27385:20170707:011506.471 using configuration file: /etc/zabbix/zabbix_agentd.conf
 27385:20170707:011506.471 cannot set resource limit: [13] Permission denied
 27385:20170707:011506.471 cannot disable core dump, exiting...

Version-Release number of selected component (if applicable):
rpm -qa 'selinux*'
selinux-policy-targeted-3.13.1-102.el7_3.16.noarch
selinux-policy-3.13.1-102.el7_3.16.noarch


How reproducible:
Always, when selinux is enforcing.  Applicable to RHEL7.3.

Steps to Reproduce:
1. Install zabbix-agent-3.2.2-1.el7.x86_64.
2. Ensure selinux is enabled
3. systemctl start zabbix-agent

Actual results:
Fails to start

Expected results:
Service starts

Additional info:
Reported as fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1323518
Workaround https://lvrabec-selinux.rhcloud.com/2016/09/19/creating-local-module-quickly-in-cil/

Comment 2 Milos Malik 2017-07-10 09:15:29 UTC
# rpm -qa selinux\*
selinux-policy-targeted-3.13.1-102.el7_3.18.noarch
selinux-policy-3.13.1-102.el7_3.18.noarch
# sesearch -s zabbix_agent_t -A -C -p setrlimit

# sesearch -s zabbix_agent_t -D -C -p setrlimit

# 

It's neither fixed nor dontaudit-ed in the latest policy for RHEL-7.3.

Comment 7 errata-xmlrpc 2018-10-30 10:00:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.