Bug 1468433 - rpc: include current second in timed out frame cleanup on client
rpc: include current second in timed out frame cleanup on client
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 01:18 EDT by Milind Changire
Modified: 2017-09-05 13:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:36:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2017-07-07 01:18:07 EDT
Description of problem:
test for cleanup should include current second i.e. timeout <= current.tv_sec
instead of timeout < current.tv_sec
Comment 1 Worker Ant 2017-07-07 01:23:10 EDT
REVIEW: https://review.gluster.org/17722 (rpc: include current second in timed out frame cleanup) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Worker Ant 2017-07-20 01:44:33 EDT
REVIEW: https://review.gluster.org/17722 (rpc: include current second in timed out frame cleanup) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)
Comment 3 Worker Ant 2017-07-21 02:22:25 EDT
COMMIT: https://review.gluster.org/17722 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 08ee8541cfc9096a7f1cb40db7d7df763256d535
Author: Milind Changire <mchangir@redhat.com>
Date:   Fri Jul 7 10:49:23 2017 +0530

    rpc: include current second in timed out frame cleanup
    
    Problem:
    frames which time out at current second are missed out
    
    Solution:
    change test to include frames timing out at current second
    i.e. timeout <= current.tv_sec
    instead of
    timeout < current.tv_sec
    
    Change-Id: I459d47856ade2b657a0289e49f7f63da29186d6e
    BUG: 1468433
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: https://review.gluster.org/17722
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Shyamsundar 2017-09-05 13:36:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.