Bug 1468451 - [RFE] Foreman Monitoring Plugin
[RFE] Foreman Monitoring Plugin
Status: CLOSED DUPLICATE of bug 1215551
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other (Show other bugs)
6.2.9
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 03:15 EDT by monish
Modified: 2017-09-04 13:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-31 10:21:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description monish 2017-07-07 03:15:30 EDT
1. Proposed title of this feature request  
            [RFE] Foreman Monitoring Plugin 
    
    2. Who is the customer behind the request?  

    Account: name and acct #  Patrick Riehecky
                             Fermilab - Business Systems
    
  
    TAM customer: no
    SRM customer: no  
    Strategic: yes  
      
    3. What is the nature and description of the request?  

   Need nagios integration in satellite.

The Foreman Monitoring Plugin [1] appears to fill a useful gap in functionality in Sat6.  Can it be considered for Sat 6.3?

RH OpenStack includes Nagios restrictions on monitoring product integration to Nagios would be sufficient for my needs.


[1] https://github.com/theforeman/foreman_monitoring



    4. Why does the customer need this? (List the business requirements here) 
As per customer's comment:

 
Sat5 included some basic monitoring features.  Sat6 is our authoritative system state source.  The ability to have Sat6 feed host information into an external monitoring tool would further cement our Sat6 system as the center of our infrastructure.  Right now I've got a tool that loads the hosts from one into the other.  However, it is a bit error prone and not as reliable as I'd like.
      

    5. How would the customer like to achieve this? (List the functional requirements here)  
As per customer's comment:

      Integrating the monitoring plugin would dramatically reduce my maintenance burden as well as help new and existing customers implement monitoring best practices with ease.

Furthermore, with the inclusion of nagios in RHOS, supported integration for monitoring would be a helpful assistance for RHOS customers.

The Foreman Monitoring plugin meets my needs.  I'd have no issue with limiting the supported integration to merely nagios (and even just the version that ships with RHOS would be fine with me).


   6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
      

    7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
-> No
      
    8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
-> Satellite 6.3 if possible
Comment 2 Bryan Kearney 2017-08-31 10:21:38 EDT

*** This bug has been marked as a duplicate of bug 1215551 ***

Note You need to log in before you can comment on or make changes to this bug.