Bug 146846 - httpd won't start. Cannot load /etc/httpd/modules/libphp4.so into server: /usr/lib/libcurl.so.3: undefined symbol: tld_strerror
httpd won't start. Cannot load /etc/httpd/modules/libphp4.so into server: /us...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 20:16 EST by Alex Roberts
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 09:03:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libcurl, libidn debug output (1.25 KB, text/plain)
2005-02-02 08:06 EST, Alex Roberts
no flags Details

  None (edit)
Description Alex Roberts 2005-02-01 20:16:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When trying to start httpd after updating the system w/ yum on 1 Feb.
2005, httpd startup process fails complaining that it cannot start due
to an undefined symbol in a curl lib. 

[root@localhost log]# /sbin/service httpd start
Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp4.so into server:
/usr/lib/libcurl.so.3: undefined symbol: tld_strerror

The version of curl installed:
curl-7.12.3-2
curl-devel-7.12.3-2



Version-Release number of selected component (if applicable):
httpd-2.0.52-3.1

How reproducible:
Always

Steps to Reproduce:
1. Try to start httpd w/ any method: service, /etc/init.d, /usr/sbin/httpd
2. Get syntax error on undefined symbol
3.
    

Actual Results:  Received error stating that libphp4.so could not be
loaded due to an undefined symbol, tld_strerror, in /usr/lib/libcurl.so.3.

Expected Results:  httpd should've started

Additional info:

httpd worked until updating curl and curl-devel today.
Comment 1 Joe Orton 2005-02-02 04:51:50 EST
Works fine for me.  Did you --nodeps an upgrade?  Was this system
upgraded from Fedora Core 2? What's the output of:

# ldd /usr/lib/libcurl.so.3
# rpm -q libidn
# ls -l /usr/lib/libidn.so.*
# ldd /usr/lib/libidn.so.*

Comment 2 Alex Roberts 2005-02-02 08:06:26 EST
Created attachment 110547 [details]
libcurl, libidn debug output
Comment 3 Alex Roberts 2005-02-02 08:10:05 EST
This was a fresh install of Fedora Core 3. I did the update of curl
and curl-devel w/ 'yum -y update curl curl-devel'. I noticed on a
couple of other FC3 systems that I cannot recreate the bug. They all
have the distinction of not having been rebooted. I'm not sure if that
makes a difference, but it's the one main difference I can think of
between those systems and the problem system.
Comment 4 Alex Roberts 2005-02-02 09:03:47 EST
I saw that libidn and libidn-devel were not the same version as the
other systems. Not sure how that happened since I only use yum to
update them and they're all pulling from the same repository. Anywho,
I updated libidn and libidn-devel using rpm instead of yum and all
seems to work now. I'll mark this as 'Not a bug' and note that the
problem is between the keyboard and chair.

Note You need to log in before you can comment on or make changes to this bug.