Bug 1468460 - Support 'error' field in JSON SSO response
Support 'error' field in JSON SSO response
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-sdk-python
Classification: oVirt
Component: Core (Show other bugs)
4.1.4
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ondra Machacek
Gonza
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 03:37 EDT by Ondra Machacek
Modified: 2018-02-12 05:09 EST (History)
3 users (show)

See Also:
Fixed In Version: python-ovirt-engine-sdk4-4.2.1-1.a1.20170718git56b2d49
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-12 05:09:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79269 master MERGED Raise proper exception when using OpenId 2017-07-18 09:00 EDT
oVirt gerrit 79558 sdk_4.1 ABANDONED Raise proper exception when using OpenId 2017-07-18 09:01 EDT

  None (edit)
Description Ondra Machacek 2017-07-07 03:37:31 EDT
OpenId Connect defines the return variable names in case of error. It requires error and error_description.

We used to use error_code instead, before, so we now need to support both 'error' and 'error_code'.
Comment 1 Oved Ourfali 2017-07-07 14:17:41 EDT
Targeting to 4.2. 
Do we need it also on 4.1.z?
Comment 2 Ondra Machacek 2017-07-11 09:57:27 EDT
No, OpenId is just for 4.2.
Comment 3 Gonza 2018-01-29 10:17:19 EST
Verified with:
ovirt-engine-4.2.1.1-0.1.el7.noarch

{"error_description":"Cannot authenticate user 'admin@internal': The username or password is incorrect..","error":"access_denied"}%
Comment 4 Sandro Bonazzola 2018-02-12 05:09:49 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.