Bug 1468462 - Edit aborted! duplicate sessions
Edit aborted! duplicate sessions
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity medium
: GA
: cfme-future
Assigned To: Jozef Zigmund
Vatsal Parekh
general:usability
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 03:37 EDT by Vatsal Parekh
Modified: 2017-07-18 02:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 10:51:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Vatsal Parekh 2017-07-07 03:37:41 EDT
Description of problem:
From configuration, when I try to change 'VMware Console Support', it gives me this error 'Edit aborted! CFME does not support the browser's back button or access from multiple tabs or windows of the same browser. Please close any duplicate sessions before proceeding.'
But, I'm the only one using this appliance. 
Video: https://goo.gl/h1xZXh

Version-Release number of selected component (if applicable):
Version 5.8.1.0.20170623170756_3ed4411
Chrome : Version 59.0.3071.115 (Official Build) (64-bit)
How reproducible:


Steps to Reproduce:
1.Configurations -> VMware Console Support
2.
3.

Actual results:
Duplicate session error

Expected results:
Changes should be there 

Additional info:
Didn't find any error or fatal on production log
Video: https://goo.gl/h1xZXh
Comment 5 Jozef Zigmund 2017-07-13 09:50:17 EDT
Hi Vatsal, I tested it and it works for me (on 5.8.z - fine branch). Could you please verify that? Please be sure that your Chrome browser has disabled the additional plugins and you operate only with 1 browser tab. If you are still able to reproduce the bug, can you send me the link to the appliance (private comment)?
Comment 6 Vatsal Parekh 2017-07-13 10:21:39 EDT
Hey Josef, 
I had sent a message regarding this on gitter/manageIQ channel. 
So, the issue seems to be the Grammerly Plugin on Chrome, even if I had disable it, I was still getting the issue. So now I completely deleted it from Chrome, and it works perfect now! I had filed many Chrome specific bugs which Devs are not able to reproduce, but seems like Grammerly was blocking some of the js stuff. I think you should close this BZ now, as even I'm not getting this error. 
Just a suggestion that, we should put this into a Note somewhere that this kind of behaviour is noted with Grammerly, maybe some user would encounter someday and we can be aware.
Comment 7 Jozef Zigmund 2017-07-13 10:51:20 EDT
Hi Vatsal, thank you for fast reply. Yes there is more plugins those can cause failures, just be aware of that. It could be JS specific plugin, but also session manipulating ones. My recommendation is, avoid to use them (have them enabled) when you are testing.

Closing the BZ as the bug was caused by browser plugin.

Note You need to log in before you can comment on or make changes to this bug.