Bug 1468502 - Image-streams for cloudforms 4.2 are incorrect in Openshift 3.4
Image-streams for cloudforms 4.2 are incorrect in Openshift 3.4
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.4.0
Unspecified Unspecified
high Severity high
: ---
: 3.4.z
Assigned To: Scott Dodson
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 05:16 EDT by Jaspreet Kaur
Modified: 2017-10-24 07:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The CFME templates have been updated to support CFME 4.5.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 14:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaspreet Kaur 2017-07-07 05:16:00 EDT
Description of problem: Since the image names have been changed the deployment of cloudforms fails 

Version-Release number of the following components:

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results: deployment fails because of incorrect/old names of cfme images


Expected results: the template names should be correct for successful deployment of cfme on openshift.

Additional info: PR for this bug

https://github.com/jkaurredhat/openshift-ansible/commit/2813b42f335f583e530da3999e5193a315ef168f
Comment 7 Gaoyun Pei 2017-07-14 04:23:56 EDT
Verify this bug with openshift-ansible-3.4.116-1.git.0.5d0e9b6.el7.noarch.rpm

After installation, check the docker image used in the cfme template
[root@ip-172-18-11-85 ~]# grep dockerImageRepository /usr/share/openshift/examples/cfme-templates/cfme-template.yaml 
    dockerImageRepository: registry.access.redhat.com/cloudforms42/cfme-openshift-app
    dockerImageRepository: registry.access.redhat.com/cloudforms42/cfme-openshift-memcached
    dockerImageRepository: registry.access.redhat.com/cloudforms42/cfme-openshift-postgresql

Create cfme template and deploy the app, check image streams
[root@ip-172-18-11-85 cfme-templates]# oc get is
NAME                        DOCKER REPO                                                         TAGS                                   UPDATED
cfme-openshift-app          registry.access.redhat.com/cloudforms42/cfme-openshift-app          latest,5.7.2.1,5.7.2.1-4 + 2 more...   9 seconds ago
cfme-openshift-memcached    registry.access.redhat.com/cloudforms42/cfme-openshift-memcached    1.4,1.4.15,1.4.15-44 + 2 more...       6 seconds ago
cfme-openshift-postgresql   registry.access.redhat.com/cloudforms42/cfme-openshift-postgresql   9.5,9.5-33,9.5-43 + 1 more...          2 seconds ago
Comment 9 errata-xmlrpc 2017-07-27 14:02:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1810

Note You need to log in before you can comment on or make changes to this bug.