Bug 146852 - yum tries to upgrade newer opensp package
yum tries to upgrade newer opensp package
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 22:01 EST by Phil Schaffner
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 23:51:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Zip file of console logs. (30.33 KB, application/x-gzip)
2005-02-01 22:03 EST, Phil Schaffner
no flags Details

  None (edit)
Description Phil Schaffner 2005-02-01 22:01:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
This may be related to BZ 144376, but not sure so opening a new one.

Did a fresh install of FC3, ran yum updates with standard FC3 base and
updates-released repos successfully, then added my favorite 3rd party
repos (dag, freshrpms, gstreamer, atrpms-stable, newrpms, local,
macromedia.mplug.org) and tried to update again.  Got numerous
seemingly-bogus conflicts, so decided to give yum-2.1.13 from rawhide
a shot at it.  Grabbed the SRPM and rebuilt from source for FC3. 
Things improved considerably after upgrade to rawhide-rebuilt
yum-2.1.13-1 - far fewer conflicts reported - but yum still tried to
install two versions of opensp.  I tried to force just the opensp
package with

# yum install opensp

and that completed OK.  Then tried again and yum wanted to "update"
opensp to a version older than the installed one. ...

# yum upgrade
... several KB  of output/errors deleted ...
Finished Transaction Test
Transaction Check Error:   package opensp-1.5.1-9.rhfc3.at (which is
newer than opensp-1.5-0_6.1.rhfc3.at) is already installed

Then tried

# yum --exclude=opensp upgrade

and that allowed the upgrade to complete.  Then

# yum upgrade

returned with no further packages to upgrade.

Have captured the logs of the entire process attached.

# ll -rt yum.*
-rw-r--r--  1 root root 76302 Feb  1 17:24 yum.err1    # Old yum
-rw-r--r--  1 root root 73307 Feb  1 18:08 yum.err2    # New yum
-rw-r--r--  1 root root  3108 Feb  1 18:12 yum.kludge1 # install
-rw-r--r--  1 root root 65588 Feb  1 18:17 yum.err3    # upgrade
-rw-r--r--  1 root root 84989 Feb  1 18:31 yum.kludge2 # exclude
-rw-r--r--  1 root root  1932 Feb  1 18:33 yum.ok      # success


Version-Release number of selected component (if applicable):
yum-2.1.13-1

How reproducible:
Didn't try

Steps to Reproduce:
1. Fresh install
2. Update with yum
3. Add 3rd party repos and upgrade again.
    

Actual Results:  Package conflicts with opensp versions.

Expected Results:  Clean update

Additional info:

See attached logs.
Comment 1 Phil Schaffner 2005-02-01 22:03:47 EST
Created attachment 110540 [details]
Zip file of console logs.

Described in original bug report.
Comment 2 Seth Vidal 2005-02-01 23:51:09 EST
okay, I've looked through all of this - there's a problem with
something trying to pull in the older opensp but I can't figure out
what yet. Right now, unless I can get a repeater that is less involved
than this I'm going to suggest that's it just an inter repo conflict
(and you do have a lot of various repos, not that they're conflicting,
just that things happen). For now.

Like I said I'll snoop around and look for some reason why the older
opensp is being pulled in, but for the moment I can't trace it back
through these logs. They aren't detailed enough, sadly. debug level 5
and higher is normally needed.

thanks
reopen if you can find a way to replicate it.

Note You need to log in before you can comment on or make changes to this bug.