Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1468580 - node reboots if a shutdown is requested via shared-disk
node reboots if a shutdown is requested via shared-disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sbd (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.5
Assigned To: Klaus Wenninger
cluster-qe@redhat.com
Steven J. Levine
:
Depends On:
Blocks: 1420851 1466531 1444020
  Show dependency treegraph
 
Reported: 2017-07-07 08:43 EDT by Klaus Wenninger
Modified: 2018-04-10 12:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: sbd-1.3.1-1.el7
Doc Type: Bug Fix
Doc Text:
A fenced node in an ‘sbd’ setup now shuts down reliably Previously, when a node received an ‘off’ via the poison pill mechanism used by ‘sbd’ on a shared disk, the node would be likely to reboot instead of powering off. With this fix, receiving an ‘off’ will power off the node. Receiving a ‘reset’ will reboot the node. If the node is not able to perform the software-driven reboot or power off properly, the watchdog is going to trigger and the action performed is what the watchdog device is configured to. A fenced node in an ‘sbd’ setup now shuts down reliably if the watchdog device is configured to power off the node, and fencing is requesting ‘off’ via the poison pill mechanism on a shared disk.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 12:55:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0924 None None None 2018-04-10 12:56 EDT

  None (edit)
Description Klaus Wenninger 2017-07-07 08:43:31 EDT
Description of problem:
In an sbd-setup where the watchdog is set to poweroff the node and fencing-action off is issued for a node via a shared-disk.

Version-Release number of selected component (if applicable):
sbd-1.3.0-3.el7

How reproducible:
100%

Steps to Reproduce:
1. setup virtual cluster using qemu-kvm
2. configure sbd using a shared disk
3. pcs stonith update {sbd-fencing-resource} method=onoff
4. pcs property set stonith-action=poweroff
3. pcs stonith fence {target-node}

Actual results:
fenced node reboots instead of shutting down

Expected results:
fenced node should shut down

Additional info:
mentioned reproduction via qemu-kvm as it is basically a race that might not be 100% reproducible on other platforms
Comment 2 Klaus Wenninger 2017-07-07 08:45:36 EDT
Fixed upstream already just missed it for 7.4.
Comment 14 Klaus Wenninger 2018-02-14 19:41:43 EST
Steven:

Guess that mixes up things now.
It really has to be distinguished between watchdog-configuration, what fencing is configured and what subsequently is signalled via poison-pill to the other side.
Guess you wanted it to be nearer to the test that lead to discovering the issue.
My approach was rather to describe which part of that went wrong and fixed now - so that other use-cases that trigger the same thing would be easier to detect/understand. I'll think over it under that light again tomorrow.
Comment 15 Klaus Wenninger 2018-02-15 11:00:21 EST
Steven:

Tried to modify the 'Doc Text' in the direction of your suggestion starting with the explicit use-case that is now working and describing a little bit what has been fixed under the hood in the paragraph following.
One semantic question arises: A watchdog is triggered (kicked) to stay calm and it triggers an action when it runs off - at least in my understanding of the words. Maybe 'trigger' should thus rather not be used in favour of 'kick' for the one thing and something like 'run off' for the other. But I'm not sure and we should probably do it consistently.
Comment 17 Steven J. Levine 2018-03-14 14:59:44 EDT
Klaus:

The first line of the description in the doc text becomes a title for the entry, and there is a character limit.  So I had to shorten the sentence to its first phrase (what the user will see at a quick glance) but moved the whole original sentence to the end of the description, since that's what this leads to.

I think that for the purposes of this release note your phrasing is fine as it.  It's really just to let somebody know what the problem was and the nature of the fix, and I think this is clear enough.
Comment 19 errata-xmlrpc 2018-04-10 12:55:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0924

Note You need to log in before you can comment on or make changes to this bug.