Bug 1468592 - runc package should require container-selinux
runc package should require container-selinux
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: runc (Show other bugs)
7.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 09:19 EDT by Steve Milner
Modified: 2018-01-25 07:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-25 07:57:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Milner 2017-07-07 09:19:52 EDT
Description of problem:

runc package does not require container-selinux

Version-Release number of selected component (if applicable):

runc-1.0.0-6.git75f8da7.fc26.1.x86_64 and possibly later


How reproducible:

Every time

Steps to Reproduce:
1. Install runc
2. Note container-selinux does not install as well
3. rpm -q --requires runc
4. Note that container-selinux is not listed

Actual results:

runc installs without container-selinux

Expected results:

container-selinux is a dependency and is installed as well via yum
Comment 2 Daniel Walsh 2017-07-08 06:31:26 EDT
Since runc labeling is handled in container-selinux we should require it be installed.  CRI-O also requires container-selinux.
Comment 7 errata-xmlrpc 2018-01-25 07:57:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0200

Note You need to log in before you can comment on or make changes to this bug.