Bug 1468595 - [RFE] Container Id and Container Name in the downward API
[RFE] Container Id and Container Name in the downward API
Status: CLOSED DUPLICATE of bug 1468596
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Weil
Xiaoli Tian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 09:24 EDT by Javier Ramirez
Modified: 2017-07-07 09:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-07 09:31:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Ramirez 2017-07-07 09:24:59 EDT
Description of problem:

We have a requirement to capture the Container Id , Container Name inside the pod.  Is there any way to pass these data by modifying template or some other way.  

https://docs.openshift.com/container-platform/3.5/dev_guide/downward_api.html

As per downward api's documentation only pod name, pod namespace, pod ip, pod labels and pod annotations are available.  Is there any way to get container id and container name as well.
Comment 1 Javier Ramirez 2017-07-07 09:31:42 EDT

*** This bug has been marked as a duplicate of bug 1468596 ***

Note You need to log in before you can comment on or make changes to this bug.