Bug 146865 - --disable-jsd causes Venkman non-working
--disable-jsd causes Venkman non-working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 04:16 EST by Pavel Hlavnicka
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 04:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Hlavnicka 2005-02-02 04:16:20 EST
Description of problem:

It§s not possible to use Venkman JavaScript Debugger witk rpm version
of firefox. (JS Debugger extension). It's a bad thing this extension
is here not only for Mozilla developers but for web developers too.

Version-Release number of selected component (if applicable):


How reproducible:

install JS Debugger extension ant try to run it from 'Tools' menu
instal from
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=1.0&os=Windows&category=Developer%20Tools&numpg=10&id=216

Steps to Reproduce:
1. instal from
https://addons.update.mozilla.org/extensions/moreinfo.php?application=firefox&version=1.0&os=Windows&category=Developer%20Tools&numpg=10&id=216

2. Run debugger from Tools menu
3.
  
Actual results:


Expected results:


Additional info:

this is due to following line in mozilla-firefox 

ac_add_options --disable-jsd

Venkman needs internal JS engine enabled for debugging. If I comment
this line out all works fine.

I believe OS distro should support web developers ;-)
Comment 1 Steven Lawrance 2005-02-02 13:50:48 EST
I totally concur. I used the Mozilla package, which I think includes
Venkman in the debugger package, and it works fine, but not in
Firefox. I put myself on a mini-mission this morning to fix this issue
so that I can remove Mozilla and just use Firefox, and I read at
http://extensionroom.mozdev.org/more-info/venkman that --disable-jsd
breaks Venkman.

Removing the "ac_add_options --disable-jsd" line is totally okay by
me. I'm actually going to custom-compile my own RPM now and,
hopefully, a future version of the package from Fedora will include
this change as well.
Comment 2 Steven Lawrance 2005-02-03 10:59:40 EST
As a follow-up, I'm confirming that changing --disable-jsd to
--enable-jsd in mozconfig-firefox made it work properly. I tested this
with firefox-1.0-8 from rawhide.
Comment 3 Christopher Aillon 2005-03-31 04:48:20 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.