Bug 1468712 - missing dependency for perl package
missing dependency for perl package
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: nginx (Show other bugs)
rh-nginx112
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 3.0
Assigned To: Luboš Uhliarik
Ondřej Pták
:
Depends On:
Blocks: 1469394
  Show dependency treegraph
 
Reported: 2017-07-07 13:08 EDT by Ondřej Pták
Modified: 2017-10-24 05:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1469394 (view as bug list)
Environment:
Last Closed: 2017-10-24 05:51:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondřej Pták 2017-07-07 13:08:10 EDT
Description of problem:
If package rh-nginx112-nginx-mod-http-perl is installed, nginx server fail to start, because of missing dependency for rh-perl524-perl-constant (and probably many others).
If I install rh-perl524-perl (wich it's dependencies), nginx server starts successfully

Version-Release number of selected component (if applicable):
rh-nginx112-nginx-mod-http-perl-1.12.0-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. start with no collection installed
2. install whole rh-nginx112 collection
3. systemctl start rh-nginx112-nginx

Actual results:
server fail to start, 

Expected results:
working nginx server

Additional info:
# scl enable rh-nginx110 -- /opt/rh/rh-nginx110/root/usr/sbin/nginx -t
Can't locate constant.pm in @INC (you may need to install the constant module) (@INC contains: /opt/rh/rh-nginx110/root/usr/lib64/perl5/vendor_perl /opt/rh/rh-perl524/root/usr/local/lib64/perl5 /opt/rh/rh-perl524/root/usr/local/share/perl5 /opt/rh/rh-perl524/root/usr/lib64/perl5/vendor_perl /opt/rh/rh-perl524/root/usr/share/perl5/vendor_perl /opt/rh/rh-perl524/root/usr/lib64/perl5 /opt/rh/rh-perl524/root/usr/share/perl5 .) at /opt/rh/rh-nginx110/root/usr/lib64/perl5/vendor_perl/nginx.pm line 60.
BEGIN failed--compilation aborted at /opt/rh/rh-nginx110/root/usr/lib64/perl5/vendor_perl/nginx.pm line 60.
Compilation failed in require.
BEGIN failed--compilation aborted.
nginx: [alert] perl_parse() failed: 2
nginx: configuration file /etc/opt/rh/rh-nginx110/nginx/nginx.conf test failed
Comment 2 Petr Pisar 2017-07-10 02:20:14 EDT
The dependencies should be named like `rh-perl524-perl(constant)'. Not `rh-perl524-perl-constant'.
Comment 7 errata-xmlrpc 2017-10-24 05:51:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3019

Note You need to log in before you can comment on or make changes to this bug.