This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1468734 - Kibana-proxy gets OOMKilled [NEEDINFO]
Kibana-proxy gets OOMKilled
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.5.z
Assigned To: Jeff Cantrill
Xia Zhao
:
Depends On: 1464020 1468987
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 15:02 EDT by Jeff Cantrill
Modified: 2017-08-31 13:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: Use underscores instead of dashes for the memory switch Result: Memory settings are respected by the nodejs runtime
Story Points: ---
Clone Of: 1464020
Environment:
Last Closed: 2017-08-31 13:00:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pportant: needinfo? (xiazhao)


Attachments (Terms of Use)
kibana proxy log (25.15 KB, text/plain)
2017-07-25 05:17 EDT, Xia Zhao
no flags Details
kibana log (519.54 KB, text/plain)
2017-07-25 05:17 EDT, Xia Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github openshift/origin-aggregated-logging/pull/522 None None None 2017-07-07 15:53 EDT

  None (edit)
Comment 3 Xia Zhao 2017-07-25 05:16:50 EDT
Tested with logging-auth-proxy image version 3.5.0-20, kibana restarted 2 times during the process of running this script, from proxy container's log, no OOM reported, and kibana can running well after doing this, set to verified:

for i in {1..300};  do    curl --fail --max-time 10 -H "Authorization: Bearer `oc whoami -t`" https://${kibana-route}/elasticsearch/ -sk > /dev/null;  done


# oc get po
NAME                          READY     STATUS    RESTARTS   AGE
logging-curator-1-30pc6       1/1       Running   0          31m
logging-es-nnsfiays-1-0cdhm   1/1       Running   0          31m
logging-fluentd-6s64m         1/1       Running   0          31m
logging-fluentd-q7fsf         1/1       Running   0          31m
logging-kibana-1-vzzbb        2/2       Running   2          31m

The kibana logs were attached.
Comment 4 Xia Zhao 2017-07-25 05:17 EDT
Created attachment 1304114 [details]
kibana proxy log
Comment 5 Xia Zhao 2017-07-25 05:17 EDT
Created attachment 1304115 [details]
kibana log
Comment 6 Peter Portante 2017-07-25 09:40:00 EDT
Can you post the output of: "oc describe pod logging-kibana-1-vzzbb"?
Comment 7 Peter Portante 2017-07-25 09:42:22 EDT
Also be aware that we can track Kibana container restarts via BZ https://bugzilla.redhat.com/show_bug.cgi?id=1465464.
Comment 9 errata-xmlrpc 2017-08-31 13:00:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1828

Note You need to log in before you can comment on or make changes to this bug.