Bug 1468762 - Cherry Smart Card Reader USB TC 1100 could not be identified
Cherry Smart Card Reader USB TC 1100 could not be identified
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcsc-lite-ccid (Show other bugs)
7.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 16:45 EDT by Steffen Froemer
Modified: 2018-04-10 13:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: pcsc-lite-ccid-1.4.10-13.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 13:59:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working Info.plist from Fedora 25 (39.54 KB, application/xml)
2017-07-07 16:45 EDT, Steffen Froemer
no flags Details
output of lsusb -v -d 046A:0090 (3.44 KB, text/plain)
2017-07-07 16:51 EDT, Steffen Froemer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0960 None None None 2018-04-10 13:59 EDT

  None (edit)
Description Steffen Froemer 2017-07-07 16:45:13 EDT
Created attachment 1295402 [details]
working Info.plist from Fedora 25

Description of problem:
The Cherry Smart Card Reader USB TC 1100 is not usable as Reader for smartcards, as it is not recognised by the system.

Version-Release number of selected component (if applicable):
pcsc-lite-ccid-1.4.10-12.el7.x86_64

How reproducible:
always on default RHEL-7 installation

Steps to Reproduce:
1. install RHEL-7.4
2. install opensc + pcsc-lite-ccid
3. run 'opensc-tool -a'

Actual results:
$ opensc-tool -a
No smart card readers found.


Expected results:
# opensc-tool -a
Using reader with a card: Cherry Smart Card Reader USB (OKCM0031411130415593851706133826) 00 00
3b:d2:18:02:c1:0a:31:fe:58:c8:0d:51


Additional info:
I replaced the file '/usr/lib64/pcsc/drivers/ifd-ccid.bundle/Contents/Info.plist ' with the one from upstream fedora package 'pcsc-lite-ccid-1.4.26-1.fc25.x86_64' and got it working.
Comment 2 Steffen Froemer 2017-07-07 16:51 EDT
Created attachment 1295404 [details]
output of lsusb -v -d 046A:0090
Comment 4 Bob Relyea 2017-08-07 16:28:46 EDT
dev_ack to add the USB_ID. QA just needs to do a sanity review. Since the card starts working with an updated Info.plist, we can be confident that the missing USB_ID is all that's needed. This is not a commitment to support any additional debugging on the reader since neither devel nor qa has access to the hardware.
Comment 7 Bob Relyea 2017-09-06 20:27:09 EDT
fixed in pcsc-lite-ccid-1.4.10-13.el7
Comment 9 Roshni 2017-12-21 11:51:53 EST
[root@dhcp129-107 ~]# rpm -qi pcsc-lite-ccid
Name        : pcsc-lite-ccid
Version     : 1.4.10
Release     : 13.el7
Architecture: x86_64
Install Date: Tue 28 Nov 2017 04:06:45 PM EST
Group       : System Environment/Libraries
Size        : 548260
License     : LGPLv2+
Signature   : RSA/SHA256, Wed 01 Nov 2017 08:14:42 PM EDT, Key ID 199e2f91fd431d51
Source RPM  : pcsc-lite-ccid-1.4.10-13.el7.src.rpm
Build Date  : Wed 06 Sep 2017 06:53:32 PM EDT
Build Host  : x86-041.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://pcsclite.alioth.debian.org/ccid.html
Summary     : Generic USB CCID smart card reader driver

Sanity Tests.
Comment 12 errata-xmlrpc 2018-04-10 13:59:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0960

Note You need to log in before you can comment on or make changes to this bug.