Bug 146878 - SMP kernel doesn't boot on UP laptop
SMP kernel doesn't boot on UP laptop
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-02-02 08:50 EST by Kjartan Maraas
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-09 04:11:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2005-02-02 08:50:28 EST
Description of problem:

Tried installing and running the current fc3 updates/testing kernel to
be able to run oprofile on my laptop and it didn't get beyond the
point where it says "uncompressing kernel image" or whatever the
wording is.

[root@localhost sysprof]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.80GHz
stepping        : 6
cpu MHz         : 1791.593
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss tm pbe est tm2
bogomips        : 3563.52

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Sitsofe Wheeler 2005-02-02 15:35:20 EST
Just for posterity what kernel are you running (rpm -q kernel)?
Comment 2 Kjartan Maraas 2005-02-02 18:06:32 EST
[kmaraas@localhost ~]$ rpm -q kernel-smp
[kmaraas@localhost ~]$
Comment 3 Kjartan Maraas 2005-02-09 03:56:42 EST
And still the same with the -1.762_FC3 kernel
Comment 4 Dave Jones 2005-02-09 04:11:23 EST
it's no surprise to me really. a lot of UP hardware (especially laptops) doesn't
like having APICs messed with.   It's unlikely that this will change any time
soon, without significant effort upstream to isolate the problems on each and
every case, and work around them accordingly.

You should be able to use oprofile in the UP kernel however, but it will use an
alternative timing source due to the lack of APIC.

Note You need to log in before you can comment on or make changes to this bug.