Bug 1468839 - cgit requires httpd instead of any webserver
cgit requires httpd instead of any webserver
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: cgit (Show other bugs)
epel7
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-08 14:16 EDT by defanor
Modified: 2017-08-09 11:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: cgit-1.1-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1138599
Environment:
Last Closed: 2017-08-09 11:23:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description defanor 2017-07-08 14:16:23 EDT
+++ This bug was initially created as a clone of Bug #1138599 +++

Description of problem:
I've installed nginx for serving several sites. Now I wanted to add cgit. It has a dependency to httpd instead of any webserver so yum installs httpd which I do not need.

Version-Release number of selected component (if applicable):
CentOS7, cgit 1.1 on x86_64

How reproducible:
Install any webserver except httpd, then install cgit and you will get an httpd

Steps to Reproduce:
1. yum install nginx
2. yum install cgit
3.

Actual results:
getting useless second webserver

Expected results:
just cgit as I've already a working webserver

Additional info:
Bug #1138599 can't be reopened, but the issue is back, so clonning it.
Comment 1 Kevin Fenzi 2017-07-24 18:29:11 EDT
Sorry about that, it seems to have gotten messed up in merging somewhere. ;( 

I'll push a fixed package in a few.
Comment 2 Fedora Update System 2017-07-24 18:46:28 EDT
cgit-1.1-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a00c707deb
Comment 3 Todd Zullinger 2017-07-24 19:48:54 EDT
With the latest cgit.spec, it looks like there is no requirement on webserver for epel builds.  Is that the desired result?  I think that the Requires: webserver should be outside of the %if 0%{?fedora} conditional.

The only difference between fedora and epel is the existence of the httpd-filesystem package on fedora, which is handled by requiring that package on fedora and directly owning%{_sysconfdir}/httpd{,/conf.d} on epel.

E.g.:

diff --git i/cgit.spec w/cgit.spec
index 4b001b8..0e1ae46 100644
--- i/cgit.spec
+++ w/cgit.spec
@@ -73,8 +73,8 @@ BuildRequires:  lua-devel
 %if 0%{?fedora}
 # just to be able to install httpd configuration correctly, FC21+
 Requires:       httpd-filesystem
-Requires:       webserver
 %endif
+Requires:       webserver
 
 
 %description
Comment 4 Kevin Fenzi 2017-07-24 19:52:14 EDT
Ugh yes, that was my intention. ;( 

You want to go ahead and push that to master and epel7?
(not that it changes master any, but I like to keep master updated and merge back from it)
Comment 5 Todd Zullinger 2017-07-24 19:54:20 EDT
Sure.  I'll do that right now...
Comment 6 Fedora Update System 2017-07-24 20:51:42 EDT
cgit-1.1-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c089298a4c
Comment 7 Fedora Update System 2017-07-25 21:48:46 EDT
cgit-1.1-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c089298a4c
Comment 8 Fedora Update System 2017-08-09 11:23:38 EDT
cgit-1.1-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.