Bug 1468844 - julia: FTBFS in Rawhide due to libgit2 0.26.x
julia: FTBFS in Rawhide due to libgit2 0.26.x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: julia (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Bouchet-Valat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-08 16:14 EDT by Igor Gnatenko
Modified: 2017-07-09 13:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-09 13:34:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2017-07-08 16:14:32 EDT
https://github.com/JuliaLang/julia/pull/22614

I suppose this PR will be enough, but check please. Rawhide has 0.26.0 since today.
Comment 1 Milan Bouchet-Valat 2017-07-08 18:10:06 EDT
I'll try that, but that branch is on the development version of Julia, so it might not backport cleanly. Aren't we supposed to first check that dependencies still build before upgrading to breaking releases of libraries?
Comment 2 Igor Gnatenko 2017-07-08 18:35:49 EDT
(In reply to Milan Bouchet-Valat from comment #1)
> I'll try that, but that branch is on the development version of Julia, so it
> might not backport cleanly. Aren't we supposed to first check that
> dependencies still build before upgrading to breaking releases of libraries?

* It's been almost month since 0.26.0 got released
* Patch is available, but I didn't have time to look at it
* Only one test failed due to updated (upper vs lower case)

P.S. it is clearly applies to v0.6.0
Comment 3 Milan Bouchet-Valat 2017-07-09 13:34:26 EDT
I don't deny that, but even if it had been release for a year, by pushing a breaking release of libgit2 you take the risk of making Julia FTBS for some time. I don't see the advantage of updating libgit2 directly, when we could have patched Julia first to ensure everything is OK. FWIW, the Updates Policy says:
>  A week in advance, notify maintainers who depend on their package
> to rebuild when there are abi/api changes that require rebuilds
> in other packages or offer to do these rebuilds for them.
https://fedoraproject.org/wiki/Updates_Policy

Anyway, I've built a new version after backporting the upstream patch plus a few tweaks.

Note You need to log in before you can comment on or make changes to this bug.