Bug 1468879 - Need identifiers on all the elements in the Nodes page, to support the automation
Need identifiers on all the elements in the Nodes page, to support the automa...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
urgent Severity urgent
: beta
: 12.0 (Pike)
Assigned To: Ana Krivokapic
Ola Pavlenko
: AutomationBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-09 05:58 EDT by Udi
Modified: 2017-12-13 16:39 EST (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-ui-7.4.3-0.20171023133305.8616195.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:39:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 483039 None None None 2017-07-12 13:19 EDT
OpenStack gerrit 510842 None None None 2017-10-10 07:29 EDT

  None (edit)
Description Udi 2017-07-09 05:58:02 EDT
Description of problem:
The new GUI in the Nodes page is too difficult to support with the Selenium automation. All the elements are div's with generic classes like "list-view-pf-description", "list-view-pf-additional-info" etc ...

For the automation we need unique identifiers on all the elements:
1) The node names, power statuses, instrospection statuses, provision statuses
2) The nodes' profile assignments, the cpu counts, the ram infos, the storage sizes
3) The checkboxes near the nodes, the expand/collapse widget
4) The Tabel view and the List view buttons in the panel, the kebab menu and the menu items in it (e.g "Delete Node"), the Introspect and Provide buttons, and the filter controls
5) The Register Nodes button, the Refresh Results button and the Select All button
6) The additional information div and all the dl/dt elements (when you expand the view of one of the nodes)


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.1.1-0.20170627161345.68e8684.el7ost.noarch
Comment 3 Jason E. Rist 2017-11-07 18:36:22 EST
I can verify that this is visible when the code is inspected and all identifiers are present.
Comment 7 errata-xmlrpc 2017-12-13 16:39:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.