Bug 1468895 - Add a playbook that changes collectd and fluentd services state and enable/disable on the engine and hosts
Add a playbook that changes collectd and fluentd services state and enable/di...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-metrics
Classification: oVirt
Component: RFEs (Show other bugs)
1.0.4.3
Unspecified Unspecified
unspecified Severity medium
: ovirt-4.1.7
: 1.0.7.1
Assigned To: Shirly Radco
Lukas Svaty
: FutureFeature
Depends On: 1502931
Blocks: 1475135 oVirt-Metrics-and-Logs 1493030
  Show dependency treegraph
 
Reported: 2017-07-09 11:18 EDT by Shirly Radco
Modified: 2017-11-14 06:43 EST (History)
5 users (show)

See Also:
Fixed In Version: ovirt-engine-metrics-1.0.7.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-13 07:29:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
ylavi: planning_ack+
sradco: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79471 master POST add manage services playbook 2017-07-17 04:34 EDT
oVirt gerrit 81494 ovirt-engine-metrics-4.1 POST add manage services playbook 2017-09-06 04:31 EDT

  None (edit)
Description Shirly Radco 2017-07-09 11:18:40 EDT
Description of problem:
In certain conditions we may want to be able to stop collectd and fluentd services on the remote hosts and engine.

This requires an ansibe playbook that will run on the engine and hosts and will stop the services.
Comment 1 Lukas Svaty 2017-10-04 07:29:36 EDT
Please add specification of this feature. Either featurePage or documentation how to manage services from the existing playbook.
Comment 2 Shirly Radco 2017-10-15 04:19:21 EDT
It is documented in the README file.

https://gerrit.ovirt.org/#/c/79471/10/packaging/setup/ansible/roles/manage_services/README.md
Comment 3 Lukas Svaty 2017-10-16 08:26:23 EDT
As we have README file I believe we need documentation, putting doc text flag to ?

For the README:

Line 3: missing comma in the end of the line
Line 5: this blank line should not be included
Line 12-14: 3 empty lines, I believe it should be just 2
Line 16-17: 2 empty lines, I believe it should be just 1
Line 20: missing comma in the end of the line
Line 31: s/these variable/these variables
Line 32: missing comma in the end of the line
Line 35: s/Ovirt/oVirt/
Line 49: s/need a configuration file/need to update the configuration file/

For the functionality:
1. # /usr/share/ovirt-engine-metrics/setup/ansible/configure_ovirt_machines_for_metrics.sh --tags=manage_services -e "service_state=stopped"
FATAL: Invalid option '-e'

2. # /usr/share/ovirt-engine-metrics/setup/ansible/configure_ovirt_machines_for_metrics.sh --tags=manage_services --help
Usage: /usr/share/ovirt-engine-metrics/setup/ansible/configure_ovirt_machines_for_metrics.sh

  --scope=SCOPE
        SCOPE is one of 'hosts', 'engine', 'all'
  --tags=TAGS
        TAGS is one of 'configure' (default), 'manage_services'

Would be nice to have better help for this, as nobody is going to find the hidden README.

3. changing config.yml
service_enabled: yes/no/wrong -> ok
service_state: restarted/started/stopped -> ok
service_name: ["collectd"]/["fluentd"]/[] -> ok


Due to the 1. and 2.  moving to FailedQA, if possible also update the README file.
Comment 4 Red Hat Bugzilla Rules Engine 2017-10-16 08:26:29 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Lukas Svaty 2017-10-19 11:37:03 EDT
[root@ ~]# /usr/share/ovirt-engine-metrics/setup/ansible/configure_ovirt_machines_for_metrics.sh -v
FATAL: Invalid option '-v'
[root@ ~]# rpm -qa | grep metrics
ovirt-engine-metrics-1.0.7-1.el7ev.noarch

patch did not get through
Comment 6 Red Hat Bugzilla Rules Engine 2017-10-19 11:37:08 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Sandro Bonazzola 2017-10-21 02:15:27 EDT
Lukas, note this has been fixed in 1.0.7.1 not 1.0.7-1
Comment 8 Lukas Svaty 2017-10-25 06:31:22 EDT
(In reply to Lukas Svaty from comment #3)
> As we have README file I believe we need documentation, putting doc text
> flag to ?
> 
> For the README:
> 
> Line 3: missing comma in the end of the line
> Line 5: this blank line should not be included
> Line 12-14: 3 empty lines, I believe it should be just 2
> Line 16-17: 2 empty lines, I believe it should be just 1
> Line 20: missing comma in the end of the line
> Line 31: s/these variable/these variables
> Line 32: missing comma in the end of the line
> Line 35: s/Ovirt/oVirt/
> Line 49: s/need a configuration file/need to update the configuration file/
> 

still relevant, we did not backport patch with README - > BZ#1506174

> For the functionality:
> 1. #
> /usr/share/ovirt-engine-metrics/setup/ansible/
> configure_ovirt_machines_for_metrics.sh --tags=manage_services -e
> "service_state=stopped"
> FATAL: Invalid option '-e'

fixed 

> 
> 2. #
> /usr/share/ovirt-engine-metrics/setup/ansible/
> configure_ovirt_machines_for_metrics.sh --tags=manage_services --help
> Usage:
> /usr/share/ovirt-engine-metrics/setup/ansible/
> configure_ovirt_machines_for_metrics.sh
> 
>   --scope=SCOPE
>         SCOPE is one of 'hosts', 'engine', 'all'
>   --tags=TAGS
>         TAGS is one of 'configure' (default), 'manage_services'
> 

still relevant BZ#1506176

> Would be nice to have better help for this, as nobody is going to find the
> hidden README.
> 
> 3. changing config.yml
> service_enabled: yes/no/wrong -> ok
> service_state: restarted/started/stopped -> ok
> service_name: ["collectd"]/["fluentd"]/[] -> ok
> 
> 

ok

> Due to the 1. and 2.  moving to FailedQA, if possible also update the README
> file.

Opened separate bugs as we dont need to block this one on them.
Verified in ovirt-engine-metrics-1.0.7.1-1.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.