Bug 1468901 - domain shows up in Hammer but not in UI [NEEDINFO]
domain shows up in Hammer but not in UI
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Networking (Show other bugs)
6.2.10
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-09 12:22 EDT by Shadd
Modified: 2018-06-22 17:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-22 17:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jcallaha: needinfo? (shadd)
dlobatog: needinfo? (shadd)


Attachments (Terms of Use)
https://127.0.0.1/domains (64.38 KB, image/png)
2017-07-09 12:22 EDT, Shadd
no flags Details

  None (edit)
Description Shadd 2017-07-09 12:22:04 EDT
Created attachment 1295636 [details]
https://127.0.0.1/domains

rhel 7.3
domainname: test.spg
dnsdomainname test.spg

Linux sat.test.spg 3.10.0-514.26.2.el7.x86_64 #1 SMP Fri Jun 30 05:26:04 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Backend System Status
Component 	Status 	Message
candlepin 	OK 	
candlepin_auth 	OK 	
foreman_tasks 	OK 	
pulp 	        OK 	
pulp_auth 	OK 	


Description of problem:
[root@sat admin]# history |grep "hammer domain"
   57  hammer domain create --name test.spg

[root@sat admin]# hammer domain list
---|---------
ID | NAME   
---|---------
1  | test.spg
---|---------

Now looking at the UI

https://127.0.0.1/domains

So on the UI MY DOMAIN THAT SHOWS UNDER HAMMER IS NOT SHOWING in UI


Version-Release number of selected component (if applicable):


How reproducible:
Multiple installs Satellite 6.2.10 same result


Steps to Reproduce:
1. hammer domain create --name test.spg
2. Goto UI at https://127.0.0.1/domains
3. Shows create new domain 



Actual results:


Expected results:
should show test.spg as the domain 

Additional info:
Comment 1 Tomas Strachota 2017-07-10 05:08:26 EDT
Hello,
can you please paste output of `hammer domain info --name test.spg` to see what organizations the domain is assigned to and check if you see the domain when you switch to "Any context" in the UI? You'll find the switcher in on the left side of the top horizontal menu.
Comment 2 Shadd 2017-07-10 07:56:44 EDT
This bug only happens when during the initial install when "satellite-installer -v --scenario satellite --capsule-puppet=true" If I remove the option and install without i am able to see the domain
Comment 3 Tomas Strachota 2017-07-10 09:11:31 EDT
Ok, this is a nice pointer. Still, would you mind checking the steps I mention in my previous comment? Thank you!
Comment 4 Shadd 2017-07-10 13:32:17 EDT
I am unable to provide info, as I am limited on resources and had to reinstall before I got your email.

all I can give you is what I tried to set it up with


satellite-installer -v --capsule-puppet=true --foreman-admin-password=redhat --foreman-admin-username=admin --foreman-initial-location=DENVER --foreman-initial-organization=REDHAT --foreman-proxy-dhcp=true --foreman-proxy-dhcp-gateway=10.168.100.1 --foreman-proxy-dhcp-interface=eth0 --foreman-proxy-dhcp-nameservers=10.168.100.233 --foreman-proxy-dhcp-range="10.168.100.20 10.168.100.250" --foreman-proxy-dns-interface=eth0 --foreman-proxy-dns-zone=test.spg --foreman-proxy-dns=true --foreman-proxy-dns-listen-on both --foreman-proxy-plugin-discovery-install-images=true --foreman-proxy-puppetca=true --foreman-proxy-templates=true --foreman-proxy-tftp=true --foreman-proxy-tftp-servername=sat.test.spg
Comment 5 jcallaha 2017-07-11 13:22:41 EDT
have you changed your organization context to any? It could be there, since you didn't specify an organization during creation.
Comment 7 Daniel Lobato Garcia 2017-12-18 11:11:21 EST
Most likely the organization/location selected in the UI didn't match those of hammer (defaults to "any context"). 

Could you try to reproduce and confirm it's a bug? I have recently installed 6.3 latest beta snap - without this issue. New domains created from facts may not have Organization, but they are visible under "Any context"

Note You need to log in before you can comment on or make changes to this bug.