Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: heketi blockvol delete returns success and removes the entry from its db, but the underlying gluster block device is not actually deleted. [root@dhcp47-10 ~]# heketi-cli blockvolume delete 0ced9f74bb5cb6d364a35f2752603c6c Volume 0ced9f74bb5cb6d364a35f2752603c6c deleted [root@dhcp47-10 ~]# [root@dhcp47-10 ~]# heketi-cli blockvolume list Id:a3b7006bde73028b651d7362f6ba78a1 Cluster:6bed12159b987cf70338ac6d1d3d0720 Name:blockvol_a3b7006bde73028b651d7362f6ba78a1 Id:b7d4e9737f20d25f0b305a10dd519076 Cluster:6bed12159b987cf70338ac6d1d3d0720 Name:blockvol_b7d4e9737f20d25f0b305a10dd519076 Id:be664f518291761bf14fd5741362b5b8 Cluster:6bed12159b987cf70338ac6d1d3d0720 Name:blockvol_be664f518291761bf14fd5741362b5b8 sh-4.2# gluster-block list vol_78dfd43a5abacb9e8365500d54d4f6e5 blockvol_a3b7006bde73028b651d7362f6ba78a1 blockvol_be664f518291761bf14fd5741362b5b8 blockvol_0ced9f74bb5cb6d364a35f2752603c6c blockvol_b7d4e9737f20d25f0b305a10dd519076 [kubeexec] ERROR 2017/07/10 03:36:13 /src/github.com/heketi/heketi/executors/kubeexec/kubeexec.go:247: Failed to run command [gluster-block delete vol_78dfd43a5abacb9e8365500d54d4f6e5/blockvol_0ced9f74bb5cb6d364a35f2752603c6c] on glusterfs-d2kf7: Err[command terminated with exit code 255]: Stdout [FAILED ON: 10.70.47.72 SUCCESSFUL ON: None RESULT: FAIL ]: Stderr [] [sshexec] ERROR 2017/07/10 03:36:13 /src/github.com/heketi/heketi/executors/sshexec/block_volume.go:88: Unable to delete volume blockvol_0ced9f74bb5cb6d364a35f2752603c6c: Unable to execute command on glusterfs-d2kf7: [heketi] INFO 2017/07/10 03:36:13 Deleted volume [0ced9f74bb5cb6d364a35f2752603c6c] [asynchttp] INFO 2017/07/10 03:36:13 asynchttp.go:129: Completed job 6a085dd07c150902251f36c5eb6e64c5 in 2m33.353576568s [negroni] Started GET /queue/6a085dd07c150902251f36c5eb6e64c5 [negroni] Completed 204 No Content in 62.914µs Version-Release number of selected component (if applicable): Images used: rhgs3/rhgs-volmanager-rhel7:3.3.0-6 rhgs3/rhgs-server-rhel7:3.3.0-6 heketi build: heketi-client-5.0.0-4.el7rhgs.x86_64 cns-deploy-5.0.0-6.el7rhgs.x86_64 gluster build: rpm -qa | grep 'gluster' glusterfs-server-3.8.4-32.el7rhgs.x86_64 gluster-block-0.2.1-4.el7rhgs.x86_64 glusterfs-libs-3.8.4-32.el7rhgs.x86_64 glusterfs-3.8.4-32.el7rhgs.x86_64 glusterfs-api-3.8.4-32.el7rhgs.x86_64 glusterfs-cli-3.8.4-32.el7rhgs.x86_64 glusterfs-fuse-3.8.4-32.el7rhgs.x86_64 glusterfs-geo-replication-3.8.4-32.el7rhgs.x86_64 glusterfs-client-xlators-3.8.4-32.el7rhgs.x86_64 How reproducible: 1/1 Steps to Reproduce: 1. create few gluster block devices from heketi 2. Tried to delete one of the gluster block device, I hit https://bugzilla.redhat.com/show_bug.cgi?id=1449245 in the first attempt 3. Once again tried to delete a gluster block device Actual results: gluster blockvol delete succeeded when underlying gluster block volume delete failed Expected results: heketi blockvolume delete should fail when underlying gluster block volume delete fails Additional info: logs shall be attached shortly
Upstream PR: https://github.com/heketi/heketi/pull/793/commits/0dd6237cc4d7c171d8a4166824504418f03a829f
verified the fix in build - cns-deploy-5.0.0-23.el7rhgs.x86_64. Gluster-block device is deleted successfully. p.s., BZ#1479777 is seen. But shouldn't hold this bug from being moved to verified.
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2017:2879