Bug 1468963 - [gluster-block]:vmcore generated when deleting the block with ha 3 when one of the node is down
[gluster-block]:vmcore generated when deleting the block with ha 3 when one o...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: CNS-deployment (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: CNS 3.6
Assigned To: Michael Adam
krishnaram Karthick
rhel-fix
:
Depends On: 1430225 1449245
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-10 01:43 EDT by krishnaram Karthick
Modified: 2017-10-11 02:58 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1449245
Environment:
Last Closed: 2017-10-11 02:58:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 8 krishnaram Karthick 2017-09-01 11:20:12 EDT
verified in build - cns-deploy-5.0.0-25.el7rhgs.x86_64

Out of the two nodes, one node was brought down and block device was deleted. delete request failed, which is expected. No crashes were seen.

[sshexec] ERROR 2017/09/01 15:17:00 /src/github.com/heketi/heketi/executors/sshexec/block_volume.go:109: Unable to get the block volume delete info for block volume blockvol_e8f64280c38bfb488f6e9d867cbe2bcd
[heketi] ERROR 2017/09/01 15:17:00 /src/github.com/heketi/heketi/apps/glusterfs/block_volume_entry.go:387: Unable to delete volume: Unable to get the block volume delete info for block volume blockvol_e8f64280c38bfb488f6e9d867cbe2bcd
[heketi] ERROR 2017/09/01 15:17:00 /src/github.com/heketi/heketi/apps/glusterfs/app_block_volume.go:189: Failed to delete volume e8f64280c38bfb488f6e9d867cbe2bcd: Unable to get the block volume delete info for block volume blockvol_e8f64280c38bfb488f6e9d867cbe2bcd
[sshexec] DEBUG 2017/09/01 15:17:00 /src/github.com/heketi/heketi/pkg/utils/ssh/ssh.go:176: Host: dhcp47-25.lab.eng.blr.redhat.com:22 Command: /bin/bash -c 'gluster-block delete vol_314b6b07b1e82a528a7bd1e2d2d00d20/blockvol_e8f64280c38bfb488f6e9d867cbe2bcd'
Result: block delete: blockvol_e8f64280c38bfb488f6e9d867cbe2bcd: failed: Some of the nodes are down
Nodes reachable:  10.70.46.1
Nodes down:  10.70.47.105
RESULT:FAIL

Moving the bug to verified.
Comment 9 errata-xmlrpc 2017-10-11 02:58:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2877

Note You need to log in before you can comment on or make changes to this bug.