Bug 14690 - kickstart unattended installation doesn't work with 2 NICs
Summary: kickstart unattended installation doesn't work with 2 NICs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-26 23:48 UTC by John Cagle
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 14:42:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Cagle 2000-07-26 23:48:27 UTC
Compaq Issue #187876:

RedHat 6.2 (and I assume earier) defaulted to eth0 for the network installation
device, but 7.0 now stops and asks which nic to use if there are more than one.

For unattended (i.e. factory) installations, a user prompt should *not* appear in the process
and therefore necessitates one of three fixes:

Option 1 - Revert to using eth0 as the download device by default,
 or
Option 2 - Allow us to specify the download device in the kickstart file.
 or
Option 3 - Some other workaround?

Compaq respectfully considers this a MUST-FIX for 7.0.

Comment 1 Michael Fulbright 2000-07-27 17:49:18 UTC
Fixed in current betas.

Be sure to use --device eth1 in the kickstart network command.

Comment 2 John Cagle 2000-07-28 20:24:48 UTC
We tried the --device option with kickstart, but that's not where the problem lies.

(Here's a note from our kickstart engineer:)

The problem is with the install loader (cant recall if its in initrd or vmlinuz).
Anyway, I have reviewed Loader.c from RH6.2 and found the locations where
eth0 is used by default or they otherwise stop at the first nic they find.
This works great if you have multiple nics because no questions are asked
 - you just always know to put the cable into the first nic.

Apparently 7.0 has changed loader.c.  Unfortunately, I dont have the source
for the beta 4 build so its a little difficult to tell what the appropriate 
command-line switch might/should be.  I assume the switch belongs
in the syslinux.cfg file on the network boot diskette.

Our current entry is:

label ks
  kernel vmlinuz
  append ks=nfs:192.168.1.22:/home/ftp/ks.cfg initrd=initrd.img network

Please advise.
Thanks!

Comment 3 Erik Troan 2000-07-31 14:53:46 UTC
ksdevice=eth1 on the kernel command line is what you're looking for

Comment 4 John Cagle 2000-08-07 14:42:15 UTC
This worked perfectly.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.