Bug 1469020 - [Docs][RFE][OpenDaylight] Document containerized deployment of OpenDaylight services
[Docs][RFE][OpenDaylight] Document containerized deployment of OpenDaylight s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: ga
: 12.0 (Pike)
Assigned To: Lukas Ruzicka
Dan Macpherson
docs-accepted
: Documentation, FutureFeature, Triaged
Depends On: 1433895
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 05:23 EDT by Lukas Ruzicka
Modified: 2018-01-10 02:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-10 02:41:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Red Hat Bugzilla Rules Engine 2017-08-02 00:15:00 EDT
This bugzilla has been removed from the release since it has not been triaged, and needs to be reviewed for targeting another release.
Comment 2 Lucy Bopf 2017-08-07 22:14:53 EDT
Assigning to Lukas for review.
Comment 17 Dan Macpherson 2017-10-03 21:01:06 EDT
"To install OpenDaylight, you have to add the links to the overcloud images list manually."

The wording makes it sound like you have to edit the files and add the image links, but in the procedure we automatically create the environment file with the command. Might need to rephrase this sentence a little to clarify.

===

"Deploy the overcloud using previously created environment files. The order of the environment files is important."

Might be an idea to mention why the order is important.

===

Might be an idea to add an additional item to the end of the command. E.g.

$ openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates \
 -e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml \
 -e /usr/share/openstack-tripleo-heat-templates/environments/neutron-opendaylight.yaml \
 -e /home/stack/templates/docker-images.yaml \
 -e /home/stack/templates/odl-images.yaml \
 [OTHER OPTIONS]

Also missing a slash at the end of the docker-images.yaml line.

Those are the only things I could spot. The procedure is pretty solid to me. Good work!
Comment 22 Dan Macpherson 2017-11-30 21:31:36 EST
Hi Lukas,

Is there anything else required from a peer review perspective here? If not, we can mark this BZ as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.