Bug 1469048 - Backup HA router sending traffic, traffic from switch interrupted
Backup HA router sending traffic, traffic from switch interrupted
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
10.0 (Newton)
x86_64 Linux
high Severity high
: z2
: 11.0 (Ocata)
Assigned To: Daniel Alvarez Sanchez
Roee Agiman
: Triaged, ZStream
Depends On: 1426735 1469051
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 06:34 EDT by Daniel Alvarez Sanchez
Modified: 2017-09-13 17:47 EDT (History)
12 users (show)

See Also:
Fixed In Version: openstack-neutron-10.0.2-6.el7ost
Doc Type: Bug Fix
Doc Text:
Neutron HA backup instances have the same IP/MAC addresses as the master instance and they have IPv6 forwarding enabled by default. This causes them to subscribe to different multicast groups and they may respond to queries coming from the external network. This traffic will make the upstream switch learn the MAC address on a different port, disrupting existing traffic to the master instance. Disable IPv6 forwarding on backup instances and restore it on failover. Traffic will not leave the backup instance to the upstream switch and will not disrupting existing connections with the master instance.
Story Points: ---
Clone Of: 1426735
Environment:
Last Closed: 2017-09-13 17:47:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1669765 None None None 2017-07-10 06:34 EDT
OpenStack gerrit 442518 None None None 2017-07-10 06:34 EDT
OpenStack gerrit 460924 None None None 2017-07-10 06:34 EDT
Red Hat Product Errata RHBA-2017:2714 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2017-09-13 21:45:43 EDT

  None (edit)
Comment 5 errata-xmlrpc 2017-09-13 17:47:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2714

Note You need to log in before you can comment on or make changes to this bug.