Bug 1469107 - python-plaster-pastedeploy-0.4.2 is available
python-plaster-pastedeploy-0.4.2 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-plaster-pastedeploy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 08:20 EDT by Upstream Release Monitoring
Modified: 2018-01-30 13:03 EST (History)
1 user (show)

See Also:
Fixed In Version: python-plaster-pastedeploy-0.4.2-1.fc28 python-plaster-pastedeploy-0.4.2-1.fc27
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-30 13:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 0.4 (#1469107) (1.04 KB, patch)
2017-07-10 08:20 EDT, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 0.4.1 (#1469107) (1.05 KB, patch)
2017-07-11 20:21 EDT, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 0.4.2 (#1469107) (1.06 KB, patch)
2017-11-21 07:25 EST, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2017-07-10 08:20:17 EDT
Latest upstream release: 0.4
Current version/release in rawhide: 0.3.2-2.fc27
URL: https://github.com/Pylons/plaster_pastedeploy

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/15598/
Comment 1 Upstream Release Monitoring 2017-07-10 08:20:21 EDT
Created attachment 1295797 [details]
[patch] Update to 0.4 (#1469107)
Comment 2 Upstream Release Monitoring 2017-07-10 08:24:46 EDT
hotness's scratch build of python-plaster-pastedeploy-0.4-1.el7.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=20440728
Comment 3 Upstream Release Monitoring 2017-07-11 20:20:59 EDT
Latest upstream release: 0.4.1
Current version/release in rawhide: 0.3.2-2.fc27
URL: https://github.com/Pylons/plaster_pastedeploy

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/15598/
Comment 4 Upstream Release Monitoring 2017-07-11 20:21:04 EDT
Created attachment 1296619 [details]
[patch] Update to 0.4.1 (#1469107)
Comment 5 Upstream Release Monitoring 2017-07-11 20:23:43 EDT
hotness's scratch build of python-plaster-pastedeploy-0.4.1-1.el7.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=20466800
Comment 6 Upstream Release Monitoring 2017-11-21 07:25:06 EST
Latest upstream release: 0.4.2
Current version/release in rawhide: 0.3.2-3.fc27
URL: https://github.com/Pylons/plaster_pastedeploy

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/15598/
Comment 7 Upstream Release Monitoring 2017-11-21 07:25:11 EST
Created attachment 1356659 [details]
[patch] Update to 0.4.2 (#1469107)
Comment 8 Upstream Release Monitoring 2017-11-21 07:26:47 EST
hotness's scratch build of python-plaster-pastedeploy-0.4.2-1.el7.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=23283043
Comment 9 Randy Barlow 2018-01-17 16:46:32 EST
It turns out that the older version of plaster-pastedeploy in F27 and Rawhide is incompatible with Pyramid >= 1.9 and causes pshell to fail like this:


# pshell production.ini 
Traceback (most recent call last):
  File "/usr/bin/pshell", line 11, in <module>
    load_entry_point('pyramid==1.9', 'console_scripts', 'pshell')()
  File "/usr/lib/python2.7/site-packages/pyramid/scripts/pshell.py", line 19, in main
    return command.run()
  File "/usr/lib/python2.7/site-packages/pyramid/scripts/pshell.py", line 122, in run
    self.pshell_file_config(loader, config_vars)
  File "/usr/lib/python2.7/site-packages/pyramid/scripts/pshell.py", line 105, in pshell_file_config
    self.loaded_objects[k] = resolver.maybe_resolve(v)
  File "/usr/lib/python2.7/site-packages/pyramid/path.py", line 320, in maybe_resolve
    return self._resolve(dotted, package)
  File "/usr/lib/python2.7/site-packages/pyramid/path.py", line 327, in _resolve
    return self._zope_dottedname_style(dotted, package)
  File "/usr/lib/python2.7/site-packages/pyramid/path.py", line 376, in _zope_dottedname_style
    found = __import__(used)
ImportError: Import by filename is not supported.

Thus, we need to fix this in F27 and Rawhide.
Comment 10 Fedora Update System 2018-01-17 18:43:27 EST
python-plaster-pastedeploy-0.4.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0e81b1d051
Comment 11 Fedora Update System 2018-01-18 19:33:50 EST
python-plaster-pastedeploy-0.4.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0e81b1d051
Comment 12 Fedora Update System 2018-01-30 13:03:30 EST
python-plaster-pastedeploy-0.4.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.