Bug 1469162 - Hammer CLI doesnt have provision to delete the subnet parameters
Hammer CLI doesnt have provision to delete the subnet parameters
Status: CLOSED DUPLICATE of bug 1426612
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Parameters (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks: 1493107
  Show dependency treegraph
 
Reported: 2017-07-10 10:27 EDT by Jitendra Yejare
Modified: 2017-09-19 08:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 07:49:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitendra Yejare 2017-07-10 10:27:56 EDT
Description of problem:
Hammer doesnt provides any option in subnet sub command to delete its parameter

Version-Release number of selected component (if applicable):
Satellite 6.3.0 snap 5

How reproducible:
Always

Steps to Reproduce:
1. Create valid subnet with valid parameter
2. Attempt to delete above subnets parameter from CLI hammer


Actual results:
Their is no such option in subnet to delete its parameter in hammer CLI

Expected results:
Their should be an option to delete the subnet parameter from CLI hammer

Additional info:
Comment 2 Tomas Strachota 2017-07-11 06:54:00 EDT
Hi Jitendra,
just to make sure, does it mean that 'hammer subnet delete-parameter' disappeared from snap 5?

hammer subnet delete-parameter -h
Usage:
    hammer subnet delete-parameter [OPTIONS]

Options:
 --name NAME                   parameter name
 --subnet SUBNET_NAME          Subnet name
 --subnet-id SUBNET_ID          
 -h, --help                    print help
Comment 3 Jitendra Yejare 2017-07-11 07:24:41 EDT
Thats True Tomas,

See this snippet:

```
# hammer -u admin -p changeme subnet delete-parameter --help
Error: No such sub-command 'delete-parameter'

See: 'hammer subnet --help'
```

But there is a bug raised already to fix this issue : https://bugzilla.redhat.com/show_bug.cgi?id=1426612

The bug is in post state already.

I think we can close this bug as duplicate of that bug.
Comment 4 Tomas Strachota 2017-07-11 07:49:18 EDT
Thanks, Jitendra. This is a dupe indeed. I'm closing it.

*** This bug has been marked as a duplicate of bug 1426612 ***

Note You need to log in before you can comment on or make changes to this bug.