Bug 146917 - setfiles (called from fixfiles) segfaults
setfiles (called from fixfiles) segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 13:47 EST by Orion Poplawski
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.21.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 19:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-02-02 13:47:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041217

Description of problem:
From sh -x fixfiles check:

+ /usr/sbin/setfiles -l -n -v
/etc/selinux/targeted/contexts/files/file_contexts / /boot/export/ftp
/export/web /usr /var
/sbin/fixfiles: line 98:  4576 Segmentation fault      ${SETFILES}
${OUTFILES} ${SYSLOGFLAG} $1 -v ${FC} ${FILESYSTEMSRW} 2>&1 >>$LOGFILE
+ exit 139

gdb /usr/sbin/setfiles
GNU gdb Red Hat Linux (6.1post-1.20040607.43rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host
libthread_db library "/lib/tls/libthread_db.so.1".

(gdb) run -l -n -v /etc/selinux/targeted/contexts/files/file_contexts
/ /boot/export/ftp/export/web /usr /var
Starting program: /usr/sbin/setfiles -l -n -v
/etc/selinux/targeted/contexts/files/file_contexts / /boot/export/ftp
/export/web /usr /var

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x080497bb in main (argc=10, argv=0xbfed66a4) at setfiles.c:505
#2  0x00948e33 in __libc_start_main () from /lib/tls/libc.so.6
#3  0x08048e61 in _start ()


Version-Release number of selected component (if applicable):
policycoreutils-1.21.9-1

How reproducible:
Didn't try

Steps to Reproduce:
1.  Not sure.
2.
3.
    

Additional info:
Comment 1 Orion Poplawski 2005-02-02 13:53:55 EST
Hmm, looks like policycoreutils-1.21.9-1 requires newer versions of libselinux
and/or libsepol:

[root@hawk ~]# rpm -qf /lib/libselinux.so.1
libselinux-1.19.1-8
[root@hawk ~]# rpm -qf /lib/libsepol.so.1
libsepol-1.1.1-2

Updated to:
  Update: libselinux.i386 0:1.21.5-1
  Update: libsepol.i386 0:1.2.1-1

and were back and running.  Looks like a Requires statement would help.
Comment 2 Daniel Walsh 2005-02-04 14:23:53 EST
Fixed the requires statement in policycoreutils-1.21.12-1

Note You need to log in before you can comment on or make changes to this bug.